No announcement yet.

Zend Guard Loader Dependency

  • Filter
  • Time
  • Show
Clear All
new posts

  • Zend Guard Loader Dependency

    Are there any plans to fix the Zend Guard Loader dependency, which only supports PHP 5.4 or lower? Ubuntu 14.04 and SUSE 12 ship with PHP 5.5, which came out 20 months ago. XAMPP is on PHP 5.5 and 5.6. PHP 7.0 is coming out in October this year (2015). PHP 5.4 has been relegated to security patches for another 6 months, while bug fixes have already died off. After that, I have to buy Red Hat or SUSE support and hope for the best. I know the lack of PHP 5.5 and PHP 5.6 support isn't directly the fault of Scriptcase, but my company has paid them full money for a product that is now only partly supported because of Scriptcase's decision to use Zend Guard.

    Scriptcase either needs to get Zend to support current PHP versions in Zend Guard Loader, or drop them. Since I don't pay Zend anything directly, I don't have the leverage of a paying customer to get Zend Guard Loader fixed. As it stands, installation is a huge pain because I have to jump through all the hoops of tracking down unsupported packages to downgrade my PHP version. At best I can still get security fixes, but bug fixes for PHP are out the window now, as are nifty new features like the large file upload support, interactive php debugger, try-catch finally block, etc.. I've heard recommendations for ionCube PHP Encoder, which at least supports PHP 5.5.

  • #2
    Moved to correct subforum.

    About topic.....
    Zend guard dependency don't affects your project. It only has to do with SC itself. I readed Zend will release Zend Guard compatible with newer versions of PHP this year.

    About all this PHP bugfixes and so on you can still be used in your projects deployed on 5.5 or 5.6. PHP 7 is coming out, but you never, NEVER have to use latest version on production.

    If Zend Guard goes on, I bet for Sourceguardian. I did some tests and works pretty well, in fact we will buy a license.
    Last edited by Giu; 03-01-2015, 07:32 AM.

    Professional Scriptcase Services
    Some Customers opinions


    • #3
      I had filed this as a bug since ScriptCase doesn't run on current versions of Ubuntu, SUSE Linux Enterprise, or XAMPP, without serious workarounds that put you in the realm of unsupported software. Requiring deprecated versions of software seems like a bug to me.

      It's nice that the dependency doesn't affect deployed projects and that you're looking at alternatives, but the dependency is still roadblocking the development of our project. I upgraded to Ubuntu 14.04 because I wanted some of the other updates & features. Now Zend Guard Loader fails to run, and by extension ScriptCase. I'm rather busy these days. It's no fun spending every bit of spare time (and some that isn't spare) tracking down dependencies and obscure errors for days and weeks, so that I can downgrade my system and make it difficult to support.