Announcement

Collapse
No announcement yet.

V7 : Upload don't work with Japanese file name !

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • V7 : Upload don't work with Japanese file name !

    Hello,

    With SC V7, upload don't work with Japanese file name (Document File Name).
    When i want to save or edit a form after putting my file in my upload field, a error appear (upload error).
    It's working fine with file in "english" character.

    No problem with V6 (same application)...

    Please try with the test file attached (Edit : this forum don't accept japanese file name too...)
    Download link : https://dl.dropbox.com/u/2457722/%EF...0%EF%BC%98.doc

    Can you correct this bug quickly please, it's very urgent !

    Thank you.
    Last edited by fizztnt; 02-17-2013, 10:24 PM.

  • #2
    Hello,

    I have reported this issue to our bugs team for further testing.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Hello,

      Any news about this bug ?
      Have you tried with the test file ?

      Thank you.

      Comment


      • #4
        I'm working in Japanese with SJIS charset and Mysql.

        For testing, i tried to create a new small application in UTF8 (database, tables, scriptcase connexion...) with upload field (filename).
        Same problem appears : files with Japanese name can not be uploaded, nothing happens. Files name with english characters are working fine (french characters too : ,,,).

        It makes my crazy, because i can not continue to develop my applications and need to use some V7 features (multiple upload, mobile menus, new PDF export).

        I don't think this bug is very difficult to correct for the Scriptcase team, because it's working with V6.

        Comment


        • #5
          Hello,

          Thanks for your feedback. I will check with our bugs team why upload isn't working properly with Japanese chars.

          regards,
          Bernhard Bernsmann

          Comment


          • #6
            Thank you Bartho,

            I made once again some upload tests with Japanese file name :

            In UTF8 : It's working only if the file name has fewer chars, like 2 or 3 characters, only with Chrome and Firefox (not working at all with IE, progress bar is blocked). With "long" file name, like my first topic, it's not working with all browsers (progress bar is blocked)
            In SJIS : Japanese file name upload are not working at all, with all browsers. No problem with the progress bar but a error message appears (upload error) after clicking the "save" or "update" button. (very strange for a Japanese charset, isn't it ?).

            I have to use SJIS to develop my applications in my company, for compatibility issues.

            Comment


            • #7
              Hello,

              Some news ???
              It's must be a problem with multibyte characters, such as the launch of SC6...

              Comment


              • #8
                Hello,

                I will get in touch with our bugs o check if there is any update on the issue.

                regards,
                Bernhard Bernsmann

                Comment


                • #9
                  Hello,

                  The problem is still here after the last update (7.0.005). Impossible to upload files with Japanese file name and SJIS charset.
                  Why it's working with V6 and not with V7 ? I really can't understand, and it makes me angry (and my coworkers too).
                  I can not continue to work with V7... What can i do ? Ask for a full reimbursement of V7 ?

                  Comment


                  • #10
                    I decided to pass my application in UTF8.
                    After some tests with the current version of SC7 and UTF8 charset (connection and database) :

                    1. It's working fine in the development server.

                    2. It's working fine in the production server ONLY IF THE FILE NAME BEGINS WITH A "ENGLISH" CHARACTER, even if the following characters are in japanese.
                    Like this file for example : https://dl.dropbox.com/u/2457722/201...1%EF%BC%95.xls

                    3. It's NOT working in the production server IF THE FILE NAME BEGINS WITH A JAPANESE CHARACTER. The progress bar is blocked at the end.
                    For exemple : https://dl.dropbox.com/u/2457722/%E3...%83%A0Ver3.doc

                    Please try !

                    Hope an update will come before the end of the next week !

                    Comment


                    • #11
                      Hello,

                      Thanks for your feedback. I'm contacting our bugs team again to check on any updates.

                      regards,
                      Bernhard Bernsmann

                      Comment


                      • #12
                        Thank you !

                        My last post is only for UTF8.
                        In SJIS charset, it's not working in the development AND production server if the file name contains 1 or more multibytes characters.

                        Please, i would like to have some news this week about this bug...
                        Now it's not "urgent"... it's "very urgent".
                        I had some complains from my boss yesterday...

                        So, i created, for test, the same application (with the same database), with the demo version of phpru**er, and upload is working fine with multibytes characters file name (japanese) in UTF8 and SJIS (with all browsers).

                        Comment


                        • #13
                          Hello,

                          Our bugs team is currently analyzing the issue. I will check the current bug status again.

                          As you have a big urgency with your current problem, I recommend you to contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                          regards,
                          Bernhard Bernsmann

                          Comment


                          • #14
                            Hello again,

                            We have fixed a few issues regarding downloads of files specifically to users that work with UTF 8. Please update your ScriptCase and let me know if the issue continues.

                            regards,
                            Bernhard Bernsmann

                            Comment


                            • #15
                              Hello,

                              Thank you for your reply.
                              My problem is UPLOAD files (not download), so the last SC update has not solve the problem. And i would like to use SJIS, not UTF8

                              After reading your reply, i still tried by curiosity (in UTF8 and SJIS), but as i thougt, the problem with multibytes characters files UPLOAD is still here...

                              IN UTF-8 :

                              1. It's working fine in the development server.

                              2. It's working fine in the production server ONLY IF THE FILE NAME BEGINS WITH A "ENGLISH" CHARACTER, even if the following characters are in japanese.
                              Like this file for example : https://dl.dropbox.com/u/2457722/201...1%EF%BC%95.xls

                              3. It's NOT working in the production server IF THE FILE NAME BEGINS WITH A JAPANESE CHARACTER. The progress bar is blocked at the end.
                              For exemple : https://dl.dropbox.com/u/2457722/%E3...%83%A0Ver3.doc


                              IN SJIS :

                              In SJIS charset, it's not working in the development AND production server if the file name contains 1 or more multibytes characters.
                              Last edited by fizztnt; 04-10-2013, 01:18 AM.

                              Comment

                              Working...
                              X