Announcement

Collapse
No announcement yet.

Upload picture - maintain aspect, Insert Mode

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload picture - maintain aspect, Insert Mode

    Hi,

    in the insert mode does not work maintain aspect feature for upload picture. Picture is still in its original size.
    This works correctly in SCv6.

    Regards

  • #2
    Hello,

    Is it on an application converted from V6? The issue could be happening due to your application settings.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Hello,

      No it is happening in new application in V7, not converted from V6.

      Maintain Aspect set as true
      width set 100px
      height set 100px

      And now uploading picture but after uploaded I got big picture in original dimensions.
      After save form I have still big picure(original dimensions) and also a great form.
      If I now refresh form picture is correctly dimensions 100x100px.
      This happens in Insert and Edit mode.

      Regards,
      Marek Otáhal

      Comment


      • #4
        Hello,

        I have reported this issue to our bugs team for further testing.

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          This is happening to me as well. i have lots of form applications converted from V6 and picture size does not re-size to the specified aspect ratio. After save and reload the form it shows the correct aspect ratio.
          When developed in V6 this worked really well but not in V7.

          Also another issue i have noted with image fields V7 is, you can not upload images anymore using Safari web browser on an iPad/iPhone. Image does not appear in the form after upload. Seems like V7 has few bugs with V7. Hopefully we'll receive an update soon.

          Comment


          • #6
            Fixed with update on Mar 12. Thank you

            Had the same problem. It is fixed now.


            Originally posted by gayan77 View Post
            This is happening to me as well. i have lots of form applications converted from V6 and picture size does not re-size to the specified aspect ratio. After save and reload the form it shows the correct aspect ratio.
            When developed in V6 this worked really well but not in V7.

            Also another issue i have noted with image fields V7 is, you can not upload images anymore using Safari web browser on an iPad/iPhone. Image does not appear in the form after upload. Seems like V7 has few bugs with V7. Hopefully we'll receive an update soon.

            Comment


            • #7
              Hello guys,

              This issue was addressed on our last release. Were you able to fix it?

              http://www.scriptcase.net/scriptcase-changelog/

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                Hi bartho,
                Last release has done something as now it is working in the development environment but still does not working in the live (production) environment.

                In my form application it is setup to save each image into a sub folder.

                Subfolder: Inspection/{Inspection_Id}/Image01

                When uploading image, progress bar moves to 100% but does not display any image. I have checked the backend and I can see the the subfolders created for each image field but there is no any images inside those folders.

                I have also submitted a ticket with copies of my database and application but haven't heard back from the support team yet.

                Comment


                • #9
                  Hello,

                  It sounds like your image isn't being written to the folder due to permission restrictions. Make sure that you have read/write permissions set to the images folder and its subfolders.

                  regards,
                  Bernhard Bernsmann

                  Comment


                  • #10
                    Yes checked the folder permission and it is all good. It creates the sub folder ok, but does not store uploaded image in that folder. This worked great in sc6.

                    Comment


                    • #11
                      Hello,

                      Please contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                      regards,
                      Bernhard Bernsmann

                      Comment


                      • #12
                        Hi bartho,
                        This is now resolved. The support team helped me to rectify the problem and the issue was with PHP version. SC7 needs PHP 5.3 or higher.

                        Comment

                        Working...
                        X