Announcement

Collapse
No announcement yet.

global variable missing with editable grid view

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • global variable missing with editable grid view

    Hi at all,
    today I created a form that ask 2 global variable,this form is created as 'single record'.All works fine.
    after I changed this form from 'single record' to 'editable grid view', the values that I filled as global variables are become missing and the form is not showed.
    If I return on form 'single record' then the global variables are asked and all works fine.



    I tested with IE,Chrome,FF but is the same.

    any help ?


  • #2
    Hello,

    In which event are you using those global variables? Are they related to a specific record (such as the record being loaded as a 'single record app')?

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      I tried in onload, onscriptinit, in SQL where condition but in any case after fiiled the value in the global variable I received the message : missing variable and the form is not showed....
      I checked the data session , when the form is in editable grid view the global variables in session after that I filled them at start , are missing...no values...

      But with same code and variables in 'single record' mode the form start and works fine....

      it seems a bug....

      Comment


      • #4
        Where are your global variables declared for the first time?
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Hello,

          Issue reported to our bugs team.

          regards,
          Bernhard Bernsmann

          Comment


          • #6
            at first time , the variables are declared in onload event I have to pass IDuser and IDclient into the form in order to fill those fields into the form.

            Comment


            • #7
              Originally posted by vivon View Post
              at first time , the variables are declared in onload event I have to pass IDuser and IDclient into the form in order to fill those fields into the form.
              I think that the onload is not fired with the gridpresentation, but the onloadrecord. Try to declare them in the onscriptinit.
              Albert Drent
              aducom software netherlands
              scriptcase partner, reseller, support and (turn-key) development
              www.scriptcase.eu / www.scriptcase.nl

              Comment


              • #8
                ARGHHHHH !!!
                I tried with the same form in SC v6 and all works fine....

                it's a BUG of SC v 7.00.0016.

                Please SC Support Team fix this bug because is very bad....!!!!

                Comment


                • #9
                  Hi Bernhard , there are news about the solution of bug ? It's too important to have this working feature ....
                  You mean that a form 'editable grid view' without a possibility to use global variables is a big problem !

                  Hey there are anybody with the same problem ?

                  please feedback !

                  Comment


                  • #10
                    Originally posted by vivon View Post
                    Hi Bernhard , there are news about the solution of bug ? It's too important to have this working feature ....
                    You mean that a form 'editable grid view' without a possibility to use global variables is a big problem !

                    Hey there are anybody with the same problem ?

                    please feedback !
                    Actually no. Did you try to declare the global in the onscriptinit?
                    Albert Drent
                    aducom software netherlands
                    scriptcase partner, reseller, support and (turn-key) development
                    www.scriptcase.eu / www.scriptcase.nl

                    Comment


                    • #11
                      Hello,

                      No updates yet from our bugs team. If this is an urgent issue, I recommend you to contact our our support. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                      regards,
                      Bernhard Bernsmann

                      Comment

                      Working...
                      X