No announcement yet.

wrong connection

  • Filter
  • Time
  • Show
Clear All
new posts

  • wrong connection

    Developing environment:
    MySql database
    3 connections pointing to the same database

    Production environment:
    MS SQL Server database
    3 connections pointing to different database

    All works fine till today.
    Today I've created a new application using only the main connection.
    When I develop it on production, it try to connect to the wrong database, maybe using a different connection.
    I tried to delete, re-create the application but no result.
    So I tried coping an old application that works, generating the code, developing it: same error, it connects itself to the wrong database.
    I'm stucked.

    By the way, I tried to renew my subscription to open a ticket but I can't do it, the web page to renew it it's down
    Attached Files

  • #2
    Hi Fabio

    Try to clean the cache.

    Giorgio Bravi
    Dolphin Software & Thinkware


    • #3
      Hi Giorgio,
      thank you for your reply.

      I tried clearing the cache (the browser cache I guess..) but the result it's the same.
      Editing the project's files I found:
      @session_start() ;
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_nm_perfil'] = "giambrocono";
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_nm_path_prod'] = "";
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_nm_path_conf'] = "";
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_nm_path_imagens'] = "";
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_nm_path_imag_temp'] = "";
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_nm_path_doc'] = "";
      $_SESSION['scriptcase']['RicercaAnagrafica']['glo_con_giambrocono_MAGIA'] = "giambrocono_MAGIA";
      Well, the connection is the wrong one, it should be "giambrocono" not "giambrocono_MAGIA".


      • #4
        Hi Fabio

        Just to know... maybe the production and developing are the same server? I had a similar problem in the past and i've solved using advanced deploy.
        Giorgio Bravi
        Dolphin Software & Thinkware


        • #5
          The production and the developing are on different server; different os and different database


          • #6
            Hello Fabio,

            Are you accessing the same system using giambrocono_MAGIA under one tab and giambrocono under another? That may be what has been causing the issue.

            Bernhard Bernsmann


            • #7
              Hey Bernhard,
              nope I tried clearing the cache, rebooting pc and then generating the code opening only my application.


              • #8
                Got it !

                The bug is in the log system.

                My default log system use the "giambrocono_MAGIA" connection.
                When I create a new grid, scriptcase put the default log system in the log page.
                The problem is that the grid use anywhere the log connection although I put another connection ("giambrocono") in the sql page
                I hope it could be fixed with next patch

                Thank you all guys for your help, I appreciate it

                Anyway I'm not satisfied about the support; from April 2011 I opened 4 tickets and I got usefull help only for the first one, the simpliest; probably I'm unlucky, but I will not pay anymore for support and I'll say it to my scriptcase students


                • #9

                  I have reported this issue to our bugs team.

                  Bernhard Bernsmann


                  • #10
                    fabiocaniggia, you try go in "Data base" -> "Edit data base" ... ? I believe there would solve your problem.


                    • #11
                      Hey FredKeyster,
                      going to Database, Edit Connection wouldn't solve the problem.
                      Neither edit or delete and recreate the connection.

                      As said, the only workaround is to disable the log system


                      • #12
                        I have had similar problems, when I changed a SQL script and the SC keept using the old one. I could not figure out how this was possible. The same have happened to the connection.
                        At this moment I have and old App which was using MySQL connection string. I copied this App and changed connection to the new generated SQLite connection. When running SC still wants to use MySQL while there is no treace or any refference for MySQL in that new App. This means that SC somehow keeps a data in some cache and doesn't properly clean it after...

                        Can you please be more specific what LOG file you talking about, perhaps knowing this could help me fix the problem in my App with the connection string and SQL code

                        Arthur Klisiewicz
                        dATA POINT SOFTWARE


                        • #13
                          Hey Arthur,

                          Going to my grid, grid-> log-> scheme.
                          Here there was specified a log scheme, I cleared it

                          Hope it could be useful to you.