Announcement

Collapse
No announcement yet.

Error after upgrading to v7.1.010

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error after upgrading to v7.1.010

    After having updated to version v7.1.010 in linux 12.04.2
    I receive the following error:
    Warning: file_get_contents() [function.file-get-contents]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /opt/NetMake/v7/wwwroot/scriptcase/index.php on line 7

    Warning: file_get_contents(http://scriptcase.sit.local:97/scriptcase/test.php) [function.file-get-contents]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known in /opt/NetMake/v7/wwwroot/scriptcase/index.php on line 7

    And the message: "Your PHP version is 5.3.21, please check the tutorial to learn how to update your php.
    Or download the version of Scriptcase appropriate for your environment."

    and cannot do anithing else. In order to follow the tutorial I need to backup mi scriptcase environment but I cannot do it from the application.
    How do I fix it?

    Thanks

  • #2
    Originally posted by nicolamersi View Post
    And the message: "Your PHP version is 5.3.21, please check the tutorial to learn how to update your php.
    For SC v7.1.0010 you must use php 5.4.
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

    Comment


    • #3
      Yes I've understood it but my situation is the following:
      1) I've updated the version from the web interface
      2) My installation is the packaged one and the php is the one distributed with the program (I think in /opt/NetMake/v7/components/apache/ext)
      3) I do not have a backup of my projects
      4) I cannot use the web interface because it does not work
      5) I need to know how to backup my projects before to reimport them in a working installation
      6) I wonder why an automatic update broke the system

      Thank you

      Comment


      • #4
        Hello,

        You must use the package available for your version of PHP. If using an old environment (PHP 5.3), just do an automatic update.
        If you want to use a PHP 5.4 environment, you should perform a new installation. Remembering that all installers are now available for PHP version 5.4 and also if you already have a PHP 5.4 environment, you can do a manual install from the compressed packages.

        http://www.scriptcase.net/upgrade-php-54/
        Best Regards,
        John L. Santos

        Bug Tracker Team
        NetMake - IT Solutions

        Comment


        • #5
          Sorry, perhaps I've not been clear:
          The firs step addressed in the doc you are pointing me "Migrating Scriptcase from PHP 5.3 to PHP 5.4" is
          1 - Perform the Scriptcase backup
          But my scriptcase do not let me login, so I cannot do a backup following the instructions
          Is there an alternative way (not Tools> Settings> Backup)?
          are the files sc_userbackup_20131108051348.zip located in /opt/NetMake/v7/wwwroot/scriptcase/backup some kind of automatic backups? Do they contain only users or also projects?

          Thank You
          Nicola

          Comment


          • #6
            Hello Nicola,

            I recommend you to get in touch with our support team.

            regards,
            Bernhard Bernsmann

            Comment


            • #7
              I have bought license only, I have no support (I think) Since it is a bug is there a sort of official support?
              Who can I ask to?

              Thank you
              Nicola

              Comment


              • #8
                I'm not an "sales expert" but since it is an issue caused by SC, I'm pretty sure you can contact our support as a trial user.

                regards,
                Bernhard Bernsmann

                Comment

                Working...
                X