Announcement

Collapse
No announcement yet.

[SOLVED] Multiple Rows Form - No new line is displayed when adding a new record

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Multiple Rows Form - No new line is displayed when adding a new record

    Hello,

    I'm using SC 7.1.
    I build a 'basic' and simple Editable Grid.
    Within, I choose to have a "Select" field (with lookup trick).
    • When I launch the form to get the result and I try to update one of the row : No Select Field appears ! Readonly mode (the others are ok, they can be filled) !
    • When I try to add a new row : No line is added in the form

    On the other side, when I set this field with "Text" type and I compile :
    • "Update" action displays an Input Text I can update ...
    • New line appears when I click on "Add" Button ...

    Would you know what happens please ?

    Thank's for your help
    CL

  • #2
    Are you sure that the 'lookup trick' reveils records? Is there no syntax error (in your sql)? Does the lookup refers to a filled table? etc.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Yes I am, because when I strictly copy/paste the lookup query in Toad for mysql which points to the good database and I execute it, it returns rows without error messages

      Comment


      • #4
        I still doubt it. Set the error options (application menu item left) to on so that you can see each sql statement before executing. You will see that SC might generate some different sql then you expect especially on lookups. I use editable grids a lot and have no issues with them, not even with lookups. So there must be something trivial, but overlooked. But hard to say from here of course ;-)
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          I did it for the involved form : debug mode + sql error.
          So, when I load the form I have some sql queries displayed and this is correct.
          But, when I click on "New" button (the default one with the Editable Rows Forms) nothing happens : no ajax error, no sql query and no reaction with the application (only the yellow little ajax Waiting panel opening shortly and closing immediatly).
          I don't understand

          Comment


          • #6
            I solved this by reinstalling my ScriptCase version and reimporting my Project.

            Comment


            • #7
              Originally posted by xof View Post
              I solved this by reinstalling my ScriptCase version and reimporting my Project.
              Hello,

              May I tag the topic as solved?

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                yes thank you

                Comment

                Working...
                X