Announcement

Collapse
No announcement yet.

Bug: INSERT INTO with invalid field ...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug: INSERT INTO with invalid field ...

    given:

    Database: MSSQL

    Form (editable grid)

    Form Settings / Fields / <myfieldname> / Generell Settings / Disabled Field => insert / update mode

    Bug: the INSERT INTO instruction contains the field name <myfieldname> ...
    Last edited by RHS; 06-05-2014, 04:31 AM.
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

  • #2
    Not sure if this is a bug, it says that the field is disabled, so not editable on your form. Might be unclear what the function should be?
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Not sure if this is a bug either. Is it changing your current field value?

      regards,
      Bernhard Bernsmann

      Comment


      • #4
        It has to do with reserved field names ...

        In my develop enviroment (SC / Win7) i use the DBMS Type "MSSQL Server NATIVE SRV PDO". Here it works without problems. In the production environment (Debian, PHP 5.4.4) is the DBMS Type "MSSQL Server" and INSERT INTO running with reserved field names to an error ...

        I find no way certain fields exclude from UPDATE or INSERT INTO commands.
        Best regards: - Reinhard -

        I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

        Comment


        • #5
          Originally posted by RHS View Post
          I find no way certain fields exclude from UPDATE or INSERT INTO commands.
          No one with a solution/workaround? Is not unusual that you do not want write to all fields ...
          Best regards: - Reinhard -

          I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

          Comment


          • #6
            Originally posted by aducom View Post
            Not sure if this is a bug, it says that the field is disabled, so not editable on your form.
            No, look at the comment after "Disabled Field": "Disable the field on some event". That's a bug and not a "feature" ...
            Best regards: - Reinhard -

            I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

            Comment


            • #7
              I don't think it makes sense to argue over Netmake's meaning of "Disabled". :-)
              The standard behaviour is, when you submit a form all fields of that form are updated/inserted no matter if they are disabled or hidden.
              You have a little influence what value is inserted by choosing the appropriate option in section Database Value at the field settings.
              If you want to change the standard behaviour the only solution / workaround is to create your own update / insert button.
              That's at least the way I do it.
              Just my 2 cts.

              jsb
              Last edited by jsbinca; 06-13-2014, 02:28 PM.

              Comment


              • #8
                Hello,

                I will contact our bugs team regarding this issue.

                regards,
                Bernhard Bernsmann

                Comment


                • #9
                  Originally posted by jsbinca View Post
                  I don't think it makes sense to argue over Netmake's meaning of "Disabled". :-)
                  Yes, unfortunately ...

                  Originally posted by jsbinca View Post
                  The standard behaviour is, when you submit a form all fields of that form are updated/inserted no matter if they are disabled or hidden.
                  I ask myself why under Form Settings / Edit Fields the column "Read-only" is present? Probably Netmake do not know also ... such clear things nerves.
                  Best regards: - Reinhard -

                  I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                  Comment

                  Working...
                  X