Announcement

Collapse
No announcement yet.

mysql_pconnect adodb-mysql issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql_pconnect adodb-mysql issue

    getting this error on production at start of login - blank screen

    /var/log/apache2/access.log:
    [:error] [pid 15326] PHP Fatal error: "GET /sec_Login/ HTTP/1.1" 500 436

    /var/log/apache2/error.log:
    Call to undefined function mysql_pconnect() in adodb/drivers/adodb-mysql.inc.php on line 391

    this is my production server:
    Description: Ubuntu 13.10
    Release: 13.10
    Codename: saucy

    PHP 5.5.13-2+deb.sury.org~saucy+1 (cli) (built: Jun 18 2014 08:31:36)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies

    this works - i am able to assign database info: .../_lib/prod/lib/php/?login

    any help is much appreciated, john

  • #2
    Originally posted by johnweimer View Post
    getting this error on production at start of login - blank screen

    /var/log/apache2/access.log:
    [:error] [pid 15326] PHP Fatal error: "GET /sec_Login/ HTTP/1.1" 500 436

    /var/log/apache2/error.log:
    Call to undefined function mysql_pconnect() in adodb/drivers/adodb-mysql.inc.php on line 391

    this is my production server:
    Description: Ubuntu 13.10
    Release: 13.10
    Codename: saucy

    PHP 5.5.13-2+deb.sury.org~saucy+1 (cli) (built: Jun 18 2014 08:31:36)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies

    this works - i am able to assign database info: .../_lib/prod/lib/php/?login

    any help is much appreciated, john
    not sure where i would of selected adodb-mysql within Scriptcase - could it be at Linode Ubuntu server level?

    Comment


    • #3
      Try with PHP 5.4
      /Giuseppe

      Professional Scriptcase Services
      Some Customers opinions

      Comment


      • #4
        thank you for your response, my development and production both match... it works in development (mac/maverick) but not production (Linode).

        SC says "Currently it is in the version 5.5.0 released on 06/20/2013, this version has fixed several bugs from previous versions, letting PHP more secure and stable."
        http://www.scriptcase.net/php/

        i would be wasting my time to go back to 5.4 on both systems, when it should work as 5.5. i have not knowingly said to use adodb..

        thank you once again for your response

        Comment


        • #5
          Are you hosted ?

          Comment


          • #6
            going from php 5.5 back to 5.4

            thank you for your response, i reverted to 5.4 as you suggested and there are issues:

            #1 Failed loading xdebug.so: dlopen(xdebug.so, 9): image not found

            #2 127.0.0.1/scriptcase/diagnosis.php does not agree with php info
            one of the many errors shows scriptcase/diagnosis as PHP: 5.4.16

            and php -v shows

            => php -v
            Failed loading xdebug.so: dlopen(xdebug.so, 9): image not found
            PHP Warning: Module 'xdebug' already loaded in Unknown on line 0

            Warning: Module 'xdebug' already loaded in Unknown on line 0
            PHP 5.4.29 (cli) (built: Jun 27 2014 09:28:01)
            Copyright (c) 1997-2014 The PHP Group
            Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
            with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans

            #3 the dreaded message of
            This Scriptcase is encrypted for a different version of php.
            Your PHP version is 5.4.16, please check the tutorial to learn how to update your php.
            Or download the version of Scriptcase appropriate for your environment.

            i have googled researching and applying the suggestions but no luck.

            scriptcase is easy and a joy to use, but its the external system administrator tweeks that kill the process.
            i spend 10% on scriptcase and 90% with linux stuff both on development and production

            i have also downloaded/re-installed many times
            Attached Files

            Comment


            • #7
              Hello,

              I recommend you to get in touch with our support team.

              Issue reported to our bugs team.

              regards,
              Bernhard Bernsmann

              Comment

              Working...
              X