Announcement

Collapse
No announcement yet.

[SOLVED] SC 7 - Chart not export to PDF perfectly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] SC 7 - Chart not export to PDF perfectly

    All,

    Since SC 7 I can not export Chart to PDF perfectly. Please see the result of chart export 2013-02-15 08.00.45 am.jpg.

    Please kindly help. I'm not sure, it is bug or not.

  • #2
    Hello,

    I have reported this issue to our bugs team for further testing.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Hi,

      my problem still exist, I don't have a clue. I use on mac, browser safari with flash plugin, last update scriptcase. please kindly help.

      Comment


      • #4
        Hello Java,

        I will check the problem status with our bugs team.

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          Hello Java,

          Could you raise the JS execution time (export configurations) from 250 to 4000? And see if the issue happens?

          regards,
          Bernhard Bernsmann

          Comment


          • #6
            Hello Bernhard,

            You are saving my life . Previously, I have adjusted js execution time to < 1000, no luck. And now 4000, it's work.
            Once again, thanks.

            Kind regards

            Comment


            • #7
              Glad I could help!

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                Still no fixed for me

                Originally posted by java View Post
                Hello Bernhard,

                You are saving my life . Previously, I have adjusted js execution time to < 1000, no luck. And now 4000, it's work.
                Once again, thanks.

                Kind regards
                I have one aplication, with several charts to export, and in my develpment enviroment work fine, in a Windows 2003 server (32 bits) with apache also fine, but in the production server (Ubuntu 12.04 64 bits + Apache + Php + Postgres), it doesnīt work. for example, a line chart, we see the points, and 1 mm of the lines with colors, and in a bar chart, we obtain the black lines, but the color no. Is like it doesnīt have enough time to draw it completly.

                We have tried to change delay from 250, to 4000 and even 8000, but stil no effects in Ubuntu server.

                Iīm trying to atach 2 pdfs, but i dont know if itīs ok.

                incidencias_informe_gra_imagen.jpgcm_nuevoinforme.jpg

                Comment


                • #9
                  Hello,

                  Please contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                  regards,
                  Bernhard Bernsmann

                  Comment


                  • #10
                    Linux bug exporting pdf because javascript-delay?

                    My mate is going to check it with the support, but i think peharps is a bug.

                    We have made several test.

                    We have put the same aplication in 4 different servers, and use the same request in each one:

                    - Windows server 2003 with apache ns4w: it works.
                    I will put the log. "wkhtmltopdf --page-size A4 --orientation Portrait --outline-depth 0 --header-right "[page]" --margin-top 1 --margin-left 1 --margin-bottom 1 --margin-right 1 --javascript-delay 4000 http://192.168.3.19/energestv7/_lib/...be3d2ab1b.html C:/ms4w/Apache/htdocs/energestv7/_lib/tmp/sc_pdf_20130619092700_20_incidencias_informe_gra_i magen.pdf"

                    - Windows server 2003 with wamp: it works.
                    Log: "wkhtmltopdf --page-size A4 --orientation Portrait --outline-depth 0 --header-right "[page]" --margin-top 1 --margin-left 1 --margin-bottom 1 --margin-right 1 --javascript-delay 4000 http://192.168.3.23/energestv7/_lib/...jkhub0ud6.html C:/wamp/www/energestv7/_lib/tmp/sc_pdf_20130619073451_390_incidencias_informe_gra_ imagen.pdf"

                    - Ubuntu 13.10 Server 64 bits + apache. It doesnīt work. Chart is showed bad.
                    Log: "./wkhtmltopdf-amd64 --page-size A4 --orientation Portrait --outline-depth 0 --header-right "[page]" --margin-top 1 --margin-left 1 --margin-bottom 1 --margin-right 1 http://192.168.3.21/energestv7/_lib/...8p2s0bl51.html /var/www/energestv7/_lib/tmp/sc_pdf_20130619092133_539_incidencias_informe_gra_ imagen.pdf"

                    - Ubuntu 12.04 Server 12.04 32 bits + apache. It doesnīt work either.
                    Log: "./wkhtmltopdf-i386 --page-size A4 --orientation Portrait --outline-depth 0 --header-right "[page]" --margin-top 1 --margin-left 1 --margin-bottom 1 --margin-right 1 http://192.168.30.128/energestv7/_li...giu6bs646.html /var/www/energestv7/_lib/tmp/sc_pdf_20130619045640_235_incidencias_informe_gra_ imagen.pdf"

                    I donīt know why, but when you call the pdf export in ubuntu, javascript-delay is not used or called.

                    Perhaps is a bug? Or in Ubuntu you canīt use that modifier?

                    Sorry, but i donīt know to quit the hypervinc of the webdirection.
                    Last edited by jaitoguer; 06-19-2013, 10:04 AM.

                    Comment


                    • #11
                      More test.

                      I tried to execute the command from terminal, adding --javascript-delay 4000, changing also wkthltopdf versions, in Ubuntu server 13.10 amd64

                      wkhtmltopdf has 3 versions.
                      9.* -> doesnīt recognize --javascript-delay parameter
                      10.* -> output error, but no warnings
                      11.* -> errors or warnings of QPixmap, and error output.

                      Comment


                      • #12
                        Perhaps set the files in directory ../lib/prod/third/wkhtmltopdf/linux-amd64 and ../linux-i386 to 755 solve this problem?
                        Best regards: - Reinhard -

                        I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                        Comment


                        • #13
                          All folders have 777 rigths (i tried 755, but just in case, i put them 777).

                          I think the problem (or at least the question), is why when you put the same web on a Linux server, --javasrcipt-delay parameter is not used (because it doesnīt appear in the log), and in a windows server that parameter takes effect and appears in the log.
                          Last edited by jaitoguer; 06-19-2013, 01:32 PM.

                          Comment


                          • #14
                            Hello,

                            I recommend you to contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                            I will also contact our bugs team regarding the problem.

                            regards,
                            Bernhard Bernsmann

                            Comment


                            • #15
                              Hi,

                              Where do you adjust this value ?

                              thank's

                              Originally posted by java View Post
                              Hello Bernhard,

                              You are saving my life . Previously, I have adjusted js execution time to < 1000, no luck. And now 4000, it's work.
                              Once again, thanks.

                              Kind regards

                              Comment

                              Working...
                              X