Announcement

Collapse
No announcement yet.

2 Generator Errors with DataGrid just after latest update 8.1.004

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2 Generator Errors with DataGrid just after latest update 8.1.004

    I am running on Windows 7 Ultimate Edition, Service Pack 1 I586

    The evening before I opened ScriptCase and Upgraded to
    ScriptCase Devel: 8.1.004
    ScriptCase Build: 1
    ScriptCase Prod: 8.1.004

    The ScriptCase server is running PHP 5.6.8

    Today I opened up ScriptCase and started on a new project which used American English as the default language and Germany German as the other language and used the German locale settings for numbers and dates appearances.

    I chose one application using the DataGrid Option

    And also created another FORM application that uses the same table as the DataGrid application.

    I went no further in Customizing all of the options for both of these applications.
    As soon as the Generate Code and Run buttons were Active I tried to see the Form and Datagrid at that rough stage.

    RESULT:

    Generating the source code and running the Form application is fine.

    BUT, trying to generate the DataGrid application keeps producing these 2 errors:

    Error 1
    2 = mkdir(): No such file or directory
    C:\Program Files (x86)\NetMake\v81\wwwroot\scriptcase\devel\generat or\nm_gp_geracao.php 301

    In this file path the file (nm_gp_geracao.php) actually exists right where it should be


    Error 2
    copy(C:/Program Files (x86)/NetMake/v81/wwwroot/scriptcase/devel/generator/language/arr_langs_tinymce.ini): failed to open stream:
    No such file or directory | Script: C:\Program Files (x86)\NetMake\v81\wwwroot\scriptcase\devel\lib\php \functions.inc.php linha: 3756

    in this file path the file (arr_langs_tinymce.ini) does NOT exist just as it warns

    To summarize: Generating Source Code and running a Form to my table that writes to this same DataGrid table executes flawlessly with no errors.
    But the DataGrid view application is producing those Generator errors.

    I am guessing that someone else will discover this as an issue or perhaps already has and can suggest a solution.

    Thank you for taking the time to read!
    Last edited by elMavericko; 10-29-2015, 01:10 PM.

  • #2
    Hello,

    Try updating the ScriptCase again. Usually this occurs is due to lack of permissions on the directory or missing files.


    Best Regards,
    John L. Santos

    Bug Tracker Team
    NetMake - IT Solutions

    Comment

    Working...
    X