Announcement

Collapse
No announcement yet.

After deploy error "The database connection was not found, Connection: conn_example"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • After deploy error "The database connection was not found, Connection: conn_example"

    When I deployed site at http://4finance.co.uk/doclib I follow the instructions to add a connection and it worked fine.

    When I try http://www.4finance.co.uk/doclib/ i get the error message "The database connection was not found, contact the system administrator. Connection: conn_example"

    When I go to my other computer and try to access the site I get the same error message "The database connection was not found, contact the system administrator. Connection: conn_example" and have to make the connection again.

    Also when I browse to http://www.4finance.co.uk/doclib/_lib/prod/ in a different browser the production environment password is back to "scriptcase"

    Example
    Firefox works with the password I created when I created the connection once I have created the connection the website works as expected.
    .firefox-prod-env.jpg


    Then when I try to use Google chrome or use the site on another computer I get the error message "The database connection was not found, contact the system administrator. Connection: conn_example" and when I go to the product enviroment I get this message and the environment password is back to scriptcase
    chrome-prod-env.jpg

    This also is the case if I change to using chrome or Opera browsers it's almost as if the connection is being saved in the browser and not on the server. Anybody else having this problem?
    Last edited by incatony; 05-01-2016, 07:14 AM. Reason: More information added

  • #2
    It looks like a rights issue. The actual database connection is stored yourproject/_lib/conf/prod.config.php
    Check the file contents before you make the database connection and afterwards.
    If so then (assuming it is apache) you need to temporarily allow write access in that yourproject/_lib/conf/ dir

    Comment


    • #3
      Thanks for the reply rr. I checked that and it's fine. When I setup the connection in firefox the database works as expected and I can log in and log out.

      Then when I open up Chrome for example and try to access the site I get "The database connection was not found, contact the system administrator. Connection: conn_example" and when I access the _lib/prod directory scriptcase password is "scriptcase" and not the one I set?

      Comment


      • #4
        As rr suggested, it is a permissions problem, changes are not stored for this reason
        /Giuseppe

        Professional Scriptcase Services
        Some Customers opinions

        Comment

        Working...
        X