No announcement yet.

[SOLVED]Error after Login as Admin into scriptcase V6

  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]Error after Login as Admin into scriptcase V6

    Hi there,

    after Login into Scriptcase V6.0.0.20 a Popup-Message appears and refers to this log:

    simplexml_load_string(): ^ | Script: C:inetpubEntwicklungscriptcasedevelclassxmlparser
    mXmlparserRSS.class.php linha: 94

    I can work normally in scriptcase, but this errormessage seems to affect the update-functions in scriptcase too.
    When I try updating scriptcase, it logs the following error:

    fopen(C:inetpubEntwicklungscriptcase/devel/conf/upd/): failed to open stream: No such file or directory | Script: C:inetpubEntwicklungscriptcasedevelclasspage
    mPageAdminUpdate2.class.php linha: 1307


    gzuncompress(): data error | Script: C:inetpubEntwicklungscriptcasedevelclasspage
    mPageAdminUpdate.class.php linha: 1173

    I tried the following:
    I renamed the referenced file from the first error to nmXmlparserRSS.class.php123 so it wont load anymore.
    Then after Login into scriptcase the screen didn't show the project overwiew anymore. Instead I had the error that the (renamed) file was missing.
    But I could open my project by clicking the open-button.
    Scriptcase-Update also worked properly and my system got updated to V6.0.0.29 now.

    But the errormessages are still the same. So whats wrong here? Please help!

    My System:
    MS Webserver 2008 R2 Virtual with IIS 7.5
    PHP 5.3.10 nts (also tried latest 5.3.15 nts)
    MS SQL Server 2008 R2 Enterprise

    Thanks alot

  • #2
    Re: Error after Login as Admin into scriptcase V6


    Please make a manual update and let me know if the issue continues.

    Bernhard Bernsmann


    • #3
      Re: Error after Login as Admin into scriptcase V6

      I tried manual update and the problem still is the same.

      I even set up a new webserver configuration with Win2008 R2, IIS 7.5, PHP 5.3.13 and edited php.ini settings like in the ini that scriptcase brings with the automatic installation file.
      IIS-config is default, I just copied the manual installation files from scriptcase zip-file into wwwroot. Gave the IUSR full access rights to wwwroot and all subfolders.
      Scriptcase install went without any error. All paths were writeable and ok.
      But on first login the error came again.

      Then I used a Windows 7 pc and installed the automatic installation file. Installation was successfull without errors. On first login I got no error and I thought that this file could be better
      for installation. But on second login into scriptcase - bang the same error came.

      I really don't know any further. I need information about the following questions:
      1. detailed iis-configuration including user permissions on file-level and config of the applicationpool.
      2. a iis-based php.ini with default php installation path on windows
      3. What about firewall issues? I have a forefront tmg 2010 with a dmz configured where the webserver resides. Webserver is áccessible from the web.
      Maybe we need special config on the webserver publication? i already figured out problems with scriptcase data dictionary and the http-filtering function in tmg.

      Any Suggestions?
      Thanks in advance,


      • #4
        Re: Error after Login as Admin into scriptcase V6


        Our team hasn't homologated IIS 7.5, that might be why you are having trouble to install SC.

        Please open a ticket, and our support team will be able to assist you to install SC properly.

        Bernhard Bernsmann


        • #5
          Re: Error after Login as Admin into scriptcase V6


          I don't really think that it is a iis-specfic problem. As i just wrote in my last message I took a win7-pc without any iis config installed and then I installed the scriptcase automatic installation file which
          includes apache2. and on the first login after installation there was no error, then logout, re-login and bang the same error as on my win2008 machine was there.
          different pc, different configuration, but same error. the only thing thats pretty identical is my firewall tmg 2010 to the web.