Announcement

Collapse
No announcement yet.

[SOLVED]Fatal error: Cannot redeclare form_employees_apl::$attachment_type

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]Fatal error: Cannot redeclare form_employees_apl::$attachment_type

    Hi All,

    I am using version 6.x 39.

    Just wanted to report that there is a bug in the forms application.
    if your field name contains the word "_type" then the form application generates a fatal error.

    for example if the field name happens to be "attachment_type" then you will receive the error in the forms application only. The Grid application works correctly.

    If the field name is renamed to "attachmenttype" then no error is generated. However this name is allmost unreadable.

    Hope the developers fix this soon as this problem did not exist before.

    Thanks for your attention.
    ************************************************** ********
    We are Developing your Future Business Requirement right now with Scriptcase.
    www.sri.com.au & www.madikonda.com

  • #2
    Hello,

    I have reported this issue to our bugs team for further testing.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Hi Bernhard, is it possible for you to ask the developers for an update?

      Thanks
      ************************************************** ********
      We are Developing your Future Business Requirement right now with Scriptcase.
      www.sri.com.au & www.madikonda.com

      Comment


      • #4
        I had a similar problem with fields named "DATA" using a connection with SqlServer. There is an open software report.
        Giorgio Bravi
        Dolphin Software & Thinkware
        www.dolphin.it

        Comment


        • #5
          Yes, sure. I will ask for an update, and also report the problem caused by fields named "DATA".

          regards,
          Bernhard Bernsmann

          Comment


          • #6
            seems like no one is able to help on this bug.

            even support has taken 2 months and not yet provided a solution.

            i will post the entire support history tomorrow for this issue to show how support behave with you even when you have a paid support.


            edit: can anyone suggest the names of a lawyer / procecuters in the same city as netmake.
            Last edited by madikonda; 02-16-2013, 08:02 AM.
            ************************************************** ********
            We are Developing your Future Business Requirement right now with Scriptcase.
            www.sri.com.au & www.madikonda.com

            Comment


            • #7
              Hello guys,

              What RDBMS are you working with? Could you send me a create table script (via PM perhaps, or email if you wish)?

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                Mysql RDBMS

                Originally posted by bartho View Post
                Hello guys,

                What RDBMS are you working with? Could you send me a create table script (via PM perhaps, or email if you wish)?

                regards,
                Bernhard Bernsmann

                I am using MySql as my database.

                To replicate this bug.

                go to any table you currently have in your application.
                then add or change a field's name to have "_type" at the end.

                example: attachment_type

                Then generate the application and then test it for yourself.


                Anil
                ************************************************** ********
                We are Developing your Future Business Requirement right now with Scriptcase.
                www.sri.com.au & www.madikonda.com

                Comment


                • #9
                  this is not a problem when using SC 5.2

                  only from SC 6 & SC7
                  ************************************************** ********
                  We are Developing your Future Business Requirement right now with Scriptcase.
                  www.sri.com.au & www.madikonda.com

                  Comment


                  • #10
                    Originally posted by madikonda View Post
                    I am using MySql as my database.

                    To replicate this bug.

                    go to any table you currently have in your application.
                    then add or change a field's name to have "_type" at the end.

                    example: attachment_type

                    Then generate the application and then test it for yourself.


                    Anil
                    Hello,

                    The problem is that our bugs team were unable to replicate the problem using MySQL. What DB engine are you working with?

                    Does it happens to any filed with "_type" at the end? For instance: CREATE TABLE TestType (ID int, test_type varchar(20))

                    regards,
                    Bernhard Bernsmann

                    Comment


                    • #11
                      Hi Bernhard,

                      I am using Mysql with MyISAM and innodb engines.

                      It happens to any field that has the name "_type" at the end. yes your example is correct.

                      The bug has been confirmed by support today by your support manager.

                      Please see support case 18214-8211122033

                      Fatal error: Cannot redeclare form_employees_apl::$attachment_type Bugs Confirmados Aguardando Correção / Awaiting Correction 11/12/2012 17:58 jefferson

                      thanks

                      Anil
                      ************************************************** ********
                      We are Developing your Future Business Requirement right now with Scriptcase.
                      www.sri.com.au & www.madikonda.com

                      Comment


                      • #12
                        Thanks for your feedback Anil.

                        I will report this issue also directly to our bugs team responsible.

                        regards,
                        Bernhard Bernsmann

                        Comment

                        Working...
                        X