Announcement

Collapse
No announcement yet.

[SOLVED]Problem with v7.0005 > v7.0006 update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]Problem with v7.0005 > v7.0006 update

    I am running suPHP and the update set file permissions to 204 and trashed everything. I had to reset permissions on files to 644 to get it to work again. Is this a problem with this update? I have updated a few files in the past with SC update and not had this problem.
    Last edited by rickallen; 03-26-2013, 05:03 PM.
    Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.

  • #2
    Hello,

    Issue reported to our bugs team.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Originally posted by bartho View Post
      Hello,

      Issue reported to our bugs team.

      regards,
      Bernhard Bernsmann
      Thanks Bernhard. Can you please post a list of files that must have executable permissions such as the ones in prod/third/wkhtmltopdf and devel/lib/third/zend?

      I had to set 755 permissions on these files to get SC to work after I reset permissions to 644 for all files. I'd like to know if there are others that need 755 to run properly. A list of required file permissions would be very helpful.
      Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.

      Comment


      • #4
        Now I am getting this: Invalid argument supplied for foreach() | Script: /home/admin53/public_html/scriptcase-7/devel/compat/nm_select_atualiza.php linha: 153
        Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.

        Comment


        • #5
          Hello Rickallen,

          I just got a reply back from our bugs team. I was informed after our last update only wkhtmltopdr, zendid, and exe files will have its permission set to 755. I.e. other files won't.

          As to the current issue, Invalid argument.. When is it happening? When you open SC? When you go to the update screen?

          regards,
          Bernhard Bernsmann

          Comment


          • #6
            The error happened when I manually updated the sql in a grid application and tried to generate it.
            Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.

            Comment


            • #7
              Thanks for the feedback. I will report the issue to our bugs team.

              Also, is the issue still happening? Is your SQL statement correct? Have you tried to run it on your RDBMS?

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                1) Make Full Backup of version 7.00.0006. (updatead)
                2) Completely uninstall it.
                3) Download version 7.00.0006 (full) of www.scriptcase.com.
                4) install.
                5) Restore Backup - Partially: Applications Projects, Users, Connections and other owner of you.
                ready.

                Comment


                • #9
                  Originally posted by bartho View Post
                  Thanks for the feedback. I will report the issue to our bugs team.

                  Also, is the issue still happening? Is your SQL statement correct? Have you tried to run it on your RDBMS?

                  regards,
                  Bernhard Bernsmann
                  Bernhard, the "nm_select_atualiza.php linha: 153 " error happens only once when I first make a manual change in SQL on a grid app, then try to generate the app. The error pops up, the generated app opens in a new window ok and looks right. When I close the generated app window, then look at the sql in the grid it does look fine. If I generate the app again, I do not get the error the second time I generate or any time after that.
                  Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.

                  Comment


                  • #10
                    Originally posted by jaroel286 View Post
                    1) Make Full Backup of version 7.00.0006. (updatead)
                    2) Completely uninstall it.
                    3) Download version 7.00.0006 (full) of www.scriptcase.com.
                    4) install.
                    5) Restore Backup - Partially: Applications Projects, Users, Connections and other owner of you.
                    ready.
                    jaroel286, I am running suPHP on my server. Will this be ok with that? I'm worried that the zip file will set permissions again. All folders need to be 755 and files 644 unless files are executable then they need to be 755.
                    Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.

                    Comment


                    • #11
                      Hello guys,

                      I was informed by our bugs team that the error happens due to a SQL error on your application(s).

                      Please make sure that there isn't any "wrong" SQL statement on your application (for instance, on lookups, events, specially on fields that aren't shown - due to lookups).

                      Remember that you can enable debug mode on application settings to help you out on that.

                      The reason why this issue didn't happened before is because SC wasn't showing SQL errors on applications. We just started exhibiting these errors on our latest release (7.006), and we will also show the location of the SQL error on upcoming releases.

                      regards,
                      Bernhard Bernsmann

                      Comment


                      • #12
                        Originally posted by bartho View Post
                        I was informed by our bugs team that the error happens due to a SQL error on your application(s).
                        Thats not correct ... The message is displayed when SC is started because no SQL statement is checked in our apps.
                        Best regards: - Reinhard -

                        I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                        Comment


                        • #13
                          Reinhard,

                          Could you elaborate? I couldn't fully understand you.

                          regards,
                          Bernhard Bernsmann

                          Comment


                          • #14
                            I start SC and the message appears ...:

                            Invalid argument supplied for foreach() | Script: /var/www/kis/scriptcase7/devel/lib/php/functions.inc.php linha: 4606
                            (I have not yet opened a project)
                            Best regards: - Reinhard -

                            I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                            Comment


                            • #15
                              Originally posted by RHS View Post
                              I start SC and the message appears ...:
                              In the "James Bond" version everything is ok ... ;-)
                              Best regards: - Reinhard -

                              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                              Comment

                              Working...
                              X