Announcement

Collapse
No announcement yet.

[SOLVED]Copy a

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]Copy a

    If I copy a template (for example elegant2) and then assign the new template to a grid's header, the template loses all the css attributes of the theme.

    Is this a bug or am I missing a step?
    Last edited by Garfieldus; 12-22-2013, 07:50 AM. Reason: finishing off title

  • #2
    UPDATE:

    If I assign the new (same) template to a form's header it retains the theme's css attributes.

    Comment


    • #3
      Ok, this thread is six days old and no response

      I will ask a different question.....

      Have you applied a copied template to a grid header AND have the header retain the theme's css attributes in the application when run?

      Comment


      • #4
        Hello,

        Issue reported to our team.

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          Originally posted by bartho View Post
          Hello,

          Issue reported to our team.

          regards,
          Bernhard Bernsmann
          Thank you.

          Comment


          • #6
            Hello,

            The Scriptcase can not know the old attributes if you are providing a new template.
            Even if you are using a copy of a template previously used, all CSS attributes are turned off to you tell the attributes that you want for the new template.
            Best Regards,
            John L. Santos

            Bug Tracker Team
            NetMake - IT Solutions

            Comment


            • #7
              Originally posted by John L. Santos View Post
              Hello,

              The Scriptcase can not know the old attributes if you are providing a new template.
              Even if you are using a copy of a template previously used, all CSS attributes are turned off to you tell the attributes that you want for the new template.

              Ok, thank you for that. Can you explain how to achieve what you are suggesting?

              Can you explain why a form retains the attributes but not a grid?

              Comment


              • #8
                Hello,

                Are you referring to the CSS template(blue) or the variables that appear in the template(red)?
                If is the variables displayed in the template, these attributes are lost in any type of application.

                template.jpg

                forgive me if I'm not clear about your problem.
                Last edited by John L. Santos; 01-02-2014, 09:58 AM.
                Best Regards,
                John L. Santos

                Bug Tracker Team
                NetMake - IT Solutions

                Comment


                • #9
                  Can I refer you to this post......

                  http://www.scriptcase.net/forum/show...ate-and-HTheme

                  Comment


                  • #10
                    Originally posted by John L. Santos View Post
                    Hello,

                    Are you referring to the CSS template(blue) or the variables that appear in the template(red)?
                    If is the variables displayed in the template, these attributes are lost in any type of application.

                    [ATTACH=CONFIG]710[/ATTACH]

                    forgive me if I'm not clear about your problem.

                    I am not saying that any of the text within the template disappears.

                    I am saying when the application is run the colours etc. disappear/change.

                    Comment


                    • #11
                      Hello,

                      I understand your problem and has simulated locally.
                      However, I'm not exactly sure but I believe the Scriptcase uses some templates internally, and that so this problem can occur.
                      I'll be checking this and even today give you an answer.
                      Best Regards,
                      John L. Santos

                      Bug Tracker Team
                      NetMake - IT Solutions

                      Comment


                      • #12
                        Hello,

                        This problem has been registered in the system to be fixed.

                        A palliative solution is you change the name of the file you copy the template, adding a '_css' to the name, as there is in the name of the original template.

                        - Scriptcase Template
                        name: /v7/wwwroot/scriptcase/devel/conf/scriptcase/tpl/header/template_name/nm_cabecalho_css.html

                        - Scriptcase Template (Copy)
                        name: /v7/wwwroot/scriptcase/devel/conf/grp/project/tpl/header/template_name/nm_cabecalho.html
                        change to nm_cabecalho_css.html too

                        Thank you!
                        Last edited by John L. Santos; 01-02-2014, 03:14 PM.
                        Best Regards,
                        John L. Santos

                        Bug Tracker Team
                        NetMake - IT Solutions

                        Comment


                        • #13
                          Ok, thank you.

                          I must say that I was beginning to lose faith because it took so long for anyone to respond.

                          Comment

                          Working...
                          X