Announcement

Collapse
No announcement yet.

[SOLVED]sc_mail_send fails when domain name has more than 2 parts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]sc_mail_send fails when domain name has more than 2 parts

    The following is consistently reproducable on my SC7.01.0014 install:

    Set a text field as "email" in a form application.

    Enter an email address that has a three part domain name, such as

    info@homeamongthegumtrees.com.au

    Submit the form and attempt to send with sc_mail_send in a suitable form event.

    sc_mail_send fails with a fatal error

    Conversely, sc_mail_send succeeds when the email address has a two part domain name such as

    info@homeamongthegumtrees.com

    Thanks
    The GuiGuy
    ... from Down Under

  • #2
    What kind of error do you get? Currently we are sending emails to an au company and afaik w.o. problems. But we use an au mail host by the way. (the mail hoster of our client)
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Correction, I get a connection refused since the update of today. Is that the same issue you have? Then it's likely that something has changed since latest update of SC
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development
      www.scriptcase.eu / www.scriptcase.nl

      Comment


      • #4
        Originally posted by aducom View Post
        Correction, I get a connection refused since the update of today. Is that the same issue you have? Then it's likely that something has changed since latest update of SC
        Yea, same here, but only on three part domain names. Incidentally, address@subdomain.domain.com also falls over.

        I switched to the basic PHP mail() function, which gets me out of trouble until they fix it.

        Cheers
        Last edited by GuiGuy; 01-19-2014, 05:53 PM.
        The GuiGuy
        ... from Down Under

        Comment


        • #5
          Funny, this morning I had not problems... Are we on the same host? It could be a hosting thing...
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #6
            Originally posted by aducom View Post
            Funny, this morning I had not problems... Are we on the same host? It could be a hosting thing...
            I have been using eboundhost (Chicago?). But if it is a hosting thing, why does PHP's mail() work?

            Cheers
            The GuiGuy
            ... from Down Under

            Comment


            • #7
              Originally posted by GuiGuy View Post
              I have been using eboundhost (Chicago?). But if it is a hosting thing, why does PHP's mail() work?
              Scrap that. I haven't tried PHP mail on the host, only locally which is using a different SMTP (AU) server. You may be onto something. I'll check some more.
              Last edited by GuiGuy; 01-20-2014, 07:40 AM. Reason: clarity
              The GuiGuy
              ... from Down Under

              Comment


              • #8
                Hello,

                This problem has been reported in our system to be fixed.
                Best Regards,
                John L. Santos

                Bug Tracker Team
                NetMake - IT Solutions

                Comment


                • #9
                  Hello,

                  I performed several tests locally and in many cases was occurring authentication error.
                  I did some searching and found that Yahoo has changed its default mode for email security.
                  All data is being encrypted because of problems with the NSA spying.

                  The question I need to know from you is, what is your email provider are you using?
                  I also performed some tests with the provider of my personal domain, everything is working normally.

                  So, I ask that you check the security settings available in the macro sc_send_mail. Check the port used and are using SSL.


                  example (no SSL):

                  $smtp = "smtp.mail.yahoo.com.br";
                  $usr = "username";
                  $pw = "password";
                  $to = "user@yahoo.com.br";
                  $from = "user@scriptcase.net";
                  $subject = "Subject";

                  $message = "You can put same text here ....".{message}.'.';

                  sc_mail_send ($smtp, $usr, $pw, $to, $from, $subject, $message, 'H', '', '', '587');


                  ************************************************** ****************************

                  example (SSL):

                  $smtp = "smtp.mail.yahoo.com.br";
                  $usr = "username";
                  $pw = "password";
                  $to = "user@yahoo.com.br";
                  $from = "user@scriptcase.net";
                  $subject = "Subject";

                  $message = "You can put same text here ....".{message}.'.';

                  sc_mail_send ($smtp, $usr, $pw, $to, $from, $subject, $message, 'H', '', '', '465','S');
                  Best Regards,
                  John L. Santos

                  Bug Tracker Team
                  NetMake - IT Solutions

                  Comment


                  • #10
                    Hi John,
                    Thanks for the feed back. I'll check that out and get back.

                    Cheers
                    The GuiGuy
                    ... from Down Under

                    Comment


                    • #11
                      U read that in the yahoo forums that yahoo (at least the uk version) now only uses the smtp.yahoo.com server so not smtp.yahoo.co.uk maybe that is also with the other yahoo versions (.br and so on).

                      Comment

                      Working...
                      X