Announcement

Collapse
No announcement yet.

Adding Fields to existing database table

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Adding Fields to existing database table

    I have a form created and decided to add a field to my corresponding table. My problem is that the new field will not show up in the fields list for the form. I've synched through the Data Dictionary several times and the field shows in the data dictionary but not in the form fields. Anyone else had this problem and how did you resolve it?

  • #2
    if you use application -> synchronize then the fields are synchronized but not put on the form by default. For that you have to go to fields positioning an put the new field(s) on your form on the wanted location (block).
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      I understand how it is intended to work however, when I go to the fields positioning the new field is not listed there for me to add to the form.

      Comment


      • #4
        Originally posted by chersey View Post
        I understand how it is intended to work however, when I go to the fields positioning the new field is not listed there for me to add to the form.
        Yes, that is the default behavior. You have to add new fields to the application as intended.

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          So how is it supposed to be done?

          Comment


          • #6
            Add the field to the SQL
            There is a SQL icon in the left menu

            Comment


            • #7
              Sorry chersey,

              I misread that. Were you able to sync your form? After syncing all fields - including the new ones - should be listed on fields positioning.

              If you are working with a grid application, simply add fields to the SQL.

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                I went into data dictionary and synched my table with the database. Then I verified that the new field is listed in the data dictionary. Then I synched with my form but the new field does not show up in the log or in the form's field positioning. On a form there is not a way to add it to the select statement in the SQL menu. The data dictionary synch is not working.

                Comment


                • #9
                  Another issue with the data dictionary synch... I have several fields that are INT in the table but on the form I have them set to SELECT. Anytime I synch, the settings are all set back to INT which means I have to go back to each field on the form and reconfigure the settings.

                  Comment


                  • #10
                    Originally posted by chersey View Post
                    Then I synched with my form but the new field does not show up in the log or in the form's field positioning.
                    I can confirm that this sometimes happens. One rule I have not found, but for me has always helped to leave SC and restart.
                    Best regards: - Reinhard -

                    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                    Comment


                    • #11
                      Originally posted by chersey View Post
                      I went into data dictionary and synched my table with the database. Then I verified that the new field is listed in the data dictionary. Then I synched with my form but the new field does not show up in the log or in the form's field positioning. On a form there is not a way to add it to the select statement in the SQL menu. The data dictionary synch is not working.
                      Hello,

                      Please contact our support if any new fields that you have, aren't being added to your form.

                      I also have contacted our bugs team regarding both issues you reported.

                      regards,
                      Bernhard Bernsmann

                      Comment


                      • #12
                        Just FYI. I did contact support and the response was "send a screenshot". Not sure what screen they want to see but asking for a screenshot for this particular issue doesn't seem to make a lot of sense.

                        Comment


                        • #13
                          They might want to know how you are syncing your application.

                          regards,
                          Bernhard Bernsmann

                          Comment

                          Working...
                          X