Announcement

Collapse
No announcement yet.

Click on this link to send this error to NetMake

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Click on this link to send this error to NetMake

    Can someone please explain for me once and for all how to handle this situation? How do I send this error file to NetMake? Do I need to purchase support in order to send an error???

    Here is an example...


    ERROR
    System Error. We recommend you to send the file with the error to NetMake.

    Log File successfully created: error_d65ff8e43f74845541115917c8a81f9f.html

    Click on this link to send this error to NetMake.


    Page with 1 queries,
    DEL: 1created in 1.02s


    Thanks!!

  • #2
    I have send these messages by clicking on the link but there's no feedback what-so-ever. I use to ignore these nowadays. Sometimes these messages appear due to an error I made, sometimes because of something wrong within scriptcase. Regenerating the app sometime removes the message or the generated application is not influenced. Very vague after all. Sometimes I have to quit sc and restart to get rid of a message.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Hello Chersey,

      Click on the link and you will receive a "full report" of the error. Once you have that I recommend you to contact us through any channel of your choice (email, support, forum, bugs), providing us a few information on how the issue happened. By doing so we can have a more detailed way to simulate the issue, and also an easier way to report back to you on the issue status.

      regards,
      Bernhard Bernsmann

      Comment


      • #4
        Originally posted by bartho View Post
        Hello Chersey,

        Click on the link and you will receive a "full report" of the error. Once you have that I recommend you to contact us through any channel of your choice (email, support, forum, bugs), providing us a few information on how the issue happened. By doing so we can have a more detailed way to simulate the issue, and also an easier way to report back to you on the issue status.

        regards,
        Bernhard Bernsmann
        This happened while working in the Search area of an application:

        Undefined offset: 6 | Script: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\class\page \nmPageFld.class.php linha: 12372

        Then in the top part of the application screen I get this:
        Id do menu nao encontrado.
        class:
        file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
        function: StartIncItensCoolJsMenu
        line: 2669
        topico -> [fields_filter_tit] Id do menu nao encontrado.
        class:
        file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
        function: StartIncItensCoolJsMenu
        line: 2669
        topico -> [fields_app_tit] Id do menu nao encontrado.
        class:
        file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
        function: StartIncItensCoolJsMenu
        line: 2669
        topico -> [link_tit]

        Comment


        • #5
          Another one...

          Undefined offset: 6 | Script: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php linha: 2675

          Id do menu nao encontrado.
          class:
          file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
          function: StartIncItensCoolJsMenu
          line: 2669
          topico -> [fields_tit] Id do menu nao encontrado.
          class:
          file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
          function: StartIncItensCoolJsMenu
          line: 2669
          topico -> [events_tit_ajax] Id do menu nao encontrado.
          class:
          file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
          function: StartIncItensCoolJsMenu
          line: 2669
          topico -> [fields_app_tit] Id do menu nao encontrado.
          class:
          file: C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\devel\lib\php\fu nctions.inc.php
          function: StartIncItensCoolJsMenu
          line: 2669
          topico -> [link_tit]

          Comment


          • #6
            Hello,

            Have you set any of those global variables?

            Is this error happening to a specific application? Or is it to all search apps?

            regards,
            Bernhard Bernsmann

            Comment


            • #7
              Sorry but I can't understand the error message. Not sure what it says.

              Comment


              • #8
                Hello,

                Have you set: [fields_tit], [events_tit_ajax], [fields_app_tit] or [link_tit]?

                Is it happening to all search applications?

                regards,
                Bernhard Bernsmann

                Comment


                • #9
                  This particular issue happened on only a single application. I had not set any of those. Actually I ended up deleting the application that was causing the problem and starting over.

                  Comment


                  • #10
                    Do you remember if there was anything that may have caused the issue? E.j. "After I created a virtual field"?

                    regards,
                    Bernhard Bernsmann

                    Comment


                    • #11
                      The only thing I can think of is that I changed a field in the database using the database builder tool. But I didn't add a new field - just changed the name of a single field. After that change I updated the application's SQL and search and to match the modified field.

                      Comment


                      • #12
                        Hello,

                        Well, just in case issue reported to our bugs team.

                        regards,
                        Bernhard Bernsmann

                        Comment


                        • #13
                          Not sure in this case of course, but to my experience this is a non-consistent error. Sometimes while generating these errors occur, but if you regenerate they might disappear. It can be all kind of errors and it's hard to reproduce. Sometimes the application refuses to run, sometimes it doesn't have any influence to the working of the application.
                          Albert Drent
                          aducom software netherlands
                          scriptcase partner, reseller, support and (turn-key) development
                          www.scriptcase.eu / www.scriptcase.nl

                          Comment


                          • #14
                            One example of a generation error (which useually disappears if you re-generate)

                            Invalid argument supplied for foreach() | Script: C:\Program Files (x86)\NetMake\v7\wwwroot\scriptcase\devel\lib\php\ database.inc.php linha: 1184
                            Albert Drent
                            aducom software netherlands
                            scriptcase partner, reseller, support and (turn-key) development
                            www.scriptcase.eu / www.scriptcase.nl

                            Comment


                            • #15
                              Originally posted by aducom View Post
                              One example of a generation error (which useually disappears if you re-generate)

                              Invalid argument supplied for foreach() | Script: C:\Program Files (x86)\NetMake\v7\wwwroot\scriptcase\devel\lib\php\ database.inc.php linha: 1184
                              I've seen that as well.

                              Comment

                              Working...
                              X