Announcement

Collapse
No announcement yet.

ScriptCase 7.1 Discussion

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Security module editing user error.

    Test it for a couple times, it's an error. The version of Scriptcase is 7.01.0009.

    1. Create a new blank project;
    2. Use Security and create security module, success;
    3. Run the app and login into, Edit the current user;
    4. Click update, and the group which the current user belongs to disppear, and the record in the table "sec_users_groups" had been deleted;
    5. Check any of the group name and save, it cannot save anything, only could add the record manually.

    Comment


    • #17
      Originally posted by scriptcasechina View Post
      Security module editing user error.

      Test it for a couple times, it's an error. The version of Scriptcase is 7.01.0009.

      1. Create a new blank project;
      2. Use Security and create security module, success;
      3. Run the app and login into, Edit the current user;
      4. Click update, and the group which the current user belongs to disppear, and the record in the table "sec_users_groups" had been deleted;
      5. Check any of the group name and save, it cannot save anything, only could add the record manually.
      Hello,

      I will contact our bugs team regarding the problem.

      regards,
      Bernhard Bernsmann

      Comment


      • #18
        Hello, Albert Drent, you wrote "I'm busy with some of the forum people setting up the beta team." How do I join this team?

        Comment


        • #19
          Currently I'm still in discussion with SC to get all things setup and for some reason (?) it takes longer then expected. So currently there isn't a beta team. It's something which needs to be setup with Scriptcase Brazil, and I would welcome a native Brazilian in the team to be a bridge in the language barier. I do speak a very little Portuguese, but by far not enough to communicate to Brazilian devs. I haven't discussed this to other potential team members, and I won't until things have been sorted out with SC Brazil.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #20
            Ok, so if your interests, you can add me into skype! "fredkeyster"!

            Comment


            • #21
              I have problem for update

              this my problem

              La clase PagePermission del módulo de Page no se encontró | Script: C:\Program Files (x86)\NetMake\v7\wwwroot\scriptcase\devel\lib\php\ functions.inc.php linha: 1153

              wats happened

              is that I have no support and can not help

              bad service you offer this company

              not open any module

              Comment


              • #22
                @machin967

                This is due to a missing file on your ScriptCase. Please try to make a manual update.
                http://www.frameworkphp.net/php/wp-c.../11/Ubarsc.jpg

                Comment


                • #23
                  Yo tambien soy nuevo,, tengo problemas con los reportes,,, el pdfreport no me ayuda mucho

                  Comment


                  • #24
                    I am working all my live critical projects (70+) in SC6 and I started using SC7 to give it a try, but very afraid to upgrade my critical projects so I started new ones in the version 7; (then I upgraded to 7.1) but I have found several issues that makes me stick to the SC6 version like:
                    - when I run (generate & execute) an application several times, to test changes and/or scripts & functions, the browser shows only the first version of the generated application (like there were no modifications or changes to the application) ; I have tryed with Chrome, IE and Firefox with same results. Since, the deployed applications runs with the lates versions I just thought "well must be a bug in this version, so will wait for a newer with this awkward symptom fixed. but the 7.1 version is still giving me the same problem. It is kind of difficult to develop a nice app without tesing it, up until deploying it to a working server.
                    - then I'm also having a deployment issue. I do most deployments via ZIP files (to avoid dealing with ftp issues that still exists in SC); But if I make any changes, I only want to deploy the modified apps instead of the whole project! specially if the project has more than 50 apps! just to run-test. So this both issues of not getting the latest version showed on the generate & execute function plus the not reliable "deployment of selected apps" issues makes me wonder how can I trust my critical projects to the new version 7? (by the way; I just discovered that the problem of not deploying only selected apps is a matter of closing the explorer between modifications to get only the selected apps for deployment.)

                    Comment


                    • #25
                      To help with SC7 translations (ln my case to spanish) there is one annoying message for a button that I'm sure we spanish speakers would like to see corrected. It is the "Save messages" button in the Languages section of the SC program; right now is translated as "Mensajes de Actualización" and that translates literally back to english as "messages of updating" or probably "updating messages". We need that message to be "Actualización de Mensajes" or just "Actualizar Mensajes" which will be far more precise and less confusing than the current translated message. Sorry, but I've been looking for a way to search and translate this message inside SC to be helpful to the community but I couldn't find it anywhere, so I choose this method to let you know.

                      Comment


                      • #26
                        Pilandros,

                        I will let our team know about your feedback.

                        thanks,
                        Bernhard Bernsmann

                        Comment


                        • #27
                          The main problem we are facing now is multilingual issue, we can not use RTL and LTR in SC together, when you chose RTL language [Arabic for example] SC remove LTR language [English]. PLEASE solve this problem soon as we really face serious difficulties because in our region people use both English and Arabic languages, unfortunately SC allow only one of them.

                          Thank You
                          Last edited by iiiax; 03-14-2014, 06:44 PM.
                          Scriptcase V8.1 Enterprise Edition.

                          Comment


                          • #28
                            tengo el scriptcase v7 y no puedo hacer algo tan facil como la suma de pedidos_detalles para que aparezca en el Monto Total de la Orden en la maestro!!!

                            Comment


                            • #29
                              DISLIKE: we have 7.1.0018 php 5.3 version and we have just installed the 7.1.0018 php 5.4 version next to it.
                              And promptly we have in de php 5.4 version problems conneting to oracle.. Of course we cant install with the instant client since that one does not fully support all codepages, only the full client supports everything. It runs in the php 5.3 version onot in the php 5.4 version.
                              Ergo what I dont like is that there was no proper testing done.... (yes those backups are a MUST HAVE....)
                              I'll try to figure out what has been broken by the 5.4 version in comparison to the 5.3 version.

                              Comment


                              • #30
                                Well I got my scriptcase 7.1 working under oracle again.. You guys should really really put some extra info somewhere on how to get it to work under windows server as service.
                                The solution is similar to how I did it before: http://www.scriptcase.net/forum/show...ghlight=oracle
                                Now in 7.1 there is no oci.dll and ociw32.dll to be renamed (that was in V6). In v7.1 you need to edit c:\Program Files (x86)\NetMake\v71\components\apache\conf\httpd.con f and edit the following line:
                                FcgidInitialEnv PATH "C:\PROGRA~2\NetMake\v71\components\php;C:\WINDOWS \system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;"

                                Change it to:
                                FcgidInitialEnv PATH "c:\oracle\ora10g\bin;C:\PROGRA~2\NetMake\v71\comp onents\php;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDO WS\System32\Wbem;"

                                Then restart the ApacheScriptcase71 service.
                                (or wherever your oracle client dll's are located of course).
                                Then check your database connection. See if it hangs when you test the connection (little circle keeps going round).
                                If so then edit your c:\Program Files (x86)\NetMake\v71\components\php\php.ini and edit it (depending on your oracle client!!).
                                You will see three lines in there for connecting to oracle:
                                extension=php_oci8.dll ; Use with Oracle 10gR2 Instant Client
                                extension=php_oci8_11g.dll ; Use with Oracle 11gR2 Instant Client
                                extension=php_pdo_oci.dll
                                In my case I have commented out the lines with: php_pdo_oci.dll that will make it work with my full oracle client. Basically I could comment out the line with php_oci8_11g.dll but that isnt needed since the first working dll gets used (in order of the ini file entry).

                                Now this service like behaviour where you need to change the FcgidInitialEnv setting is likely to occur on other databases as well. It surprises me that there is no document on this... There should be!

                                Comment

                                Working...
                                X