Announcement

Collapse
No announcement yet.

Compiling applications using remote connections DON'T WORK

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compiling applications using remote connections DON'T WORK

    I might be missing something, lack of understanding whatever it is..

    I have brought this issue before but received not 1 single response, not sure why I am the only 1 having the problem.

    Scriptcase will NOT compile an application that points to a remote server, the compile process simply hangs and never goes to completion because compiling ("GENERATE") is actually attempting to make a connection to the "remote" server and should NOT!!!!.

    The connection to the remote server can change at the time the application is deployed so why attempt to make a connection during development, the application will work once is deployed to the remote server provided the connection has been properly configured ????? ...

  • #2
    I'am using only remote connections for develop and can't confirm ...

    Can you upload an sample app and give me the detail to the remote connection (via PN)?
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

    Comment


    • #3
      Yes, can you describe what you are doing? We are developing from home on our dev systems at the university using vpn. I'm using remote desktop and at home I work on any laptop/pc on the server in my intranet. Also we provide sc support to customers using RDS, logmein and teamviewer. And all with no problems.
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development
      www.scriptcase.eu / www.scriptcase.nl

      Comment


      • #4
        Originally posted by aducom View Post
        Yes, can you describe what you are doing? We are developing from home on our dev systems at the university using vpn. I'm using remote desktop and at home I work on any laptop/pc on the server in my intranet. Also we provide sc support to customers using RDS, logmein and teamviewer. And all with no problems.
        I am not using VPN so I am not sure what you mean, this is a simple grid application trying to connect to a remote server.
        The problem is that when I click on the grid app to "generate" it Scriptcase goes into a loop and never returns from compiling/generating the app.
        I noted 3 problems:
        1) Sometimes I can connect to the server and sometimes I can't - This morning I was able to make a connection using MySqlWorkBench but sometimes I can't do it so maybe the connection has firewalls or something preventing the connection but at the least MySqlWorkBench and ScritpCase should come back not end up in an endless loop but they both do.
        2) I have a blank application that points to the same remote connection and that did compile ok the grid however is not compiling, ScriptCase goes into an endless loop and never completes compiling the grid this is the reason I said that Scritpcase seems to attempt to "make the connection" to the server while compiling I thought this was odd.
        3) Today I was able to make a connection while editing the remote connection in Scriptcase so I hit the "Save" button and immediately got a Warning that goes like this:
        Warming: incompatible charset encoding (see attached pic)
        The charset of your database utf8 is incompatible with some charset found in your project (ISO-8859-1). Do you wan to change the charsets below to UTF-8 automatically? below I see ISO-8859-1 with a check box already checked and options YES/No, when I click on YES Scriptcase goes into an endless loop and never comes back.

        I checked my database tables and I see they are charsets "Latin1", so I clicked on the ADVANCED option for the connection in Scriptcase and see utf8 is automatically selected for me (see 2nd attached pic). Can someone help me with this and do you think the problem might the related to the charsets???...
        Attached Files

        Comment


        • #5
          Ok... It's obvious that SC needs to have access to the database to retrieve field info etc. So I can imagine that if your database connection isn't stable the rest will fail to. I don't think it's a firewall issue because then you would never have access or always. It's more likely that the amount of connections is limited, you have some kind of IP error etc. If you have problems with your charset then you need to adjust that in your connection settings. The charsets of your database and connection(s) needs to match. But so far I can see SC is working fine, but you have some kind of (mis) configuration problem. It's hard to tell from here what the problem is.
          Last edited by aducom; 10-26-2013, 04:14 PM.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #6
            Ok nothing I can do for those connections I will need some inside help to resolve it but I wanted to ask your help on understanding the "charsets" problem. When I created the database for this project it took the default which is "LATIN1". I show this when I go to MySql and run this command: SHOW CREATE DATABASE salesdb
            CREATE DATABASE `salesdb` /*!40100 DEFAULT CHARACTER SET latin1 */

            Now when I went to save the connection under Scriptcase the "ADVANCED" screen shows "UTF8" where I get this warning below when saving the connection.

            Warning: incompatible charset encoding
            The charset of your database utf8 is incompatible with some charsets found in your project )ISO-8859-1). Do you want to change the charsets below to UTF-8 automatically ?

            ISO-8859-1 is checked off.

            I am developing a project in Spanish so I have chosen Spanish as primary and English as secondary languages so when I go to the project Properties I see under tab "Locales"
            English = (UTF-8)
            Espaņol/Spanish = (UTF-8)

            So the warning message above confuses me, it is asking me if I want to change ISO-885901 to UTF-8 right? I am not sure where ISO-8859-1 comes from the project Properties window for this project in Scriptcase shows UTF-8 not ISO-859-1 ???

            Question: If my database default is Latin1 what charset should the project in Scriptcase be?

            Comment


            • #7
              http://webmonkeyuk.wordpress.com/201...roblems-in-php as you see ISO 8859-1 is the other name for latin1.
              So the remark for 8859-1 conversion is not really a surprise. I'd say, go easy and move everything to utf 8
              The basic rule of thumb is to have php and the database in the same characterset.
              Last edited by rr; 10-29-2013, 08:04 AM.

              Comment

              Working...
              X