Announcement

Collapse
No announcement yet.

Can Not define a MSSQL connection, i did it but is not saved, also production environ

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can Not define a MSSQL connection, i did it but is not saved, also production environ

    Whenever set the connection it is verified Ok, but never saved.

    Also the production environment password is not saved either..

    I granted all permissions (Full Control) to IIS_IUSRS in the _lib directory.......

    Please Help...

    Plase Help.

  • #2
    This is a similar issue as discussed in a pretty long thread not so long ago. I'm prettty much convinced that this is a IIS issue. Granting permission, thread pools, application pools, IIS is a *very* complicated webserver with an overload of options to set/reset. I advise you to get into contact with SC support, preferable by chat. I know they are not very responsive, but I always managed to get into contact after a while (keep in mind that timetable might be different).

    If you want a robust solution I recommend shutting IIS on your windows server down and replace it with Apache. I.e. from a Wamp package. That's how we solved the issues after moving from W2003 server to W2008 and now 12 server. The options are very well documented, loads of forums to put your questions to and there are packages who come out-of-the-box with production configuration. If you want a recommendation PM me as I will not mention these products here any more (even if they are open-source)

    But running on Windows server you might want to run IIS too. But there's no easy answer so I hope you will be able to figure it out with the help of SC.
    Of course if you manage to get it running on IIS please share the solution. I'm sure others would like to know.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      @nfxmap1: have you installed your PHP manuell in IIS oder have you used WPI (Web Platform Installer)?
      Best regards: - Reinhard -

      I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

      Comment


      • #4
        Reinhard,
        Do you have a running and working IIS instance? It would be helpful if you could provide a tutorial on how to do that. In my experiences it's virtually impossible to go over all the settings of IIS to try to find out what checkbox is set wrong or what setting needs to be fulfilled. We couldn't manage it, which is why we switched to apache. And I can rely on very experienced people.This will (again) become a long thread without a solution I'm affraid.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Originally posted by RHS View Post
          @nfxmap1: have you installed your PHP manuell in IIS oder have you used WPI (Web Platform Installer)?
          I installed PHP Manually , i did not know there was a WPI install.

          Comment


          • #6
            Ok, de-install the php version and re-install with WPI.
            Best regards: - Reinhard -

            I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

            Comment


            • #7
              @nfxmap1:

              Next step after re-install with WPI: try this solution (steps #12 - #17, with your (!) namespaces). This solution is for wordpress, but works for many php apps ...
              Best regards: - Reinhard -

              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

              Comment

              Working...
              X