Announcement

Collapse
No announcement yet.

[SOLVED] Connection Error - PostgreSQL 9

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Connection Error - PostgreSQL 9

    I can't connect to postgres from scriptcase. I get the error below :

    Database connection failed

    pg_connect(): Unable to connect to PostgreSQL server: SSL error: length too short
    How could I solve this issue?

  • #2
    Maybe posting your connection parameters can show something. Just with this error, who knows....
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      Please see the attached image for the connection parameters.

      postgres_error.jpg

      Comment


      • #4
        Dont see nothing weird. Can you connect with same credentials with pgadmin?
        /Giuseppe

        Professional Scriptcase Services
        Some Customers opinions

        Comment


        • #5
          Yes. I could connect with the same credentials through pgadmin.

          Comment


          • #6
            Hello,

            Have you followed our tutorial to make sure you aren't missing anything? http://www.scriptcase.net/docs/en_us...ql/postgressql

            regards,
            Bernhard Bernsmann

            Comment


            • #7
              No, it was manually enabled in php.ini.

              Also, in my diagnosis, it says that PostgresSQL is already enabled.

              Diagnosis - Database Screenshot :
              diagnosis-database.jpg
              Last edited by seth; 09-03-2014, 04:50 AM.

              Comment


              • #8
                Hi,

                Have you set persistent connection to "Yes" under the connection advanced settings?

                http://www.scriptcase.net/docs/en_us...ostgresql3.png

                regards,
                Bernhard

                Comment


                • #9
                  No. I didn't set it to "Yes". Should I set it to "Yes"?

                  Comment


                  • #10
                    Hello,

                    This issue has been resolved. Someone from the support team concluded that the error was caused by PostgreSQL SSL authentication, and given me the following solutions :
                    1- Disable the SSL cryptography in PostgresSQL and restart the service.

                    or

                    2- Allow a private and public key to access the Database through SSL authentication.
                    The first solution works for me. Although, I still haven't tried the second solution 'coz it is more complicated.

                    If ever you encounter the same error, this might help.

                    Comment


                    • #11
                      Marked as solved, close the thread.
                      /Giuseppe

                      Professional Scriptcase Services
                      Some Customers opinions

                      Comment

                      Working...
                      X