No announcement yet.

Installing SC7 manually on linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing SC7 manually on linux

    I am attempting to install SC7 on a NAS which is a Linux box. I currently have PHP 5.3 and Zend Guard Loader 3.3 for PHP 5.3 installed and working. I also have Java Manager installed and MySQL. When I start Scriptcase for the very first time, I just get a screen full of gargbage characters:

    Z[o~v6%X""E:uIʶ IX wJPHЇKѷ@o@ߒ}Cߙ%h[\&22gmΙ;OãG{*ǵ=~}| *2&K:R8q#po霥NO*~k6zeت )^&F!n~B-]IriSpr4l21W3\Lfͻ4NȀ1b"f +"<^"!YcKD:O28NB.elW# b2)ԐS6SrQߪ՚WuE`Quc%By Z9Ͱ]ˌ#*V "j({jEj*hFKET&iG }L! wE)4=B`;wd;`E&{0ͽ½)pǚ A <z*`$3R(ᒷr#}l`9_y1/rZR_+v`9y2OFQ{sqyөI/Na0N:[ "mibrr2~P\ivL|O[Z"'.;V& \Bxrdn=jbxY4S$-hP㱤DQ2.`/jb_m%Rpny@4yf!rO^9۸=~>W-+Yda&f@7@GGr^\C=hy=~)7N[;;P BVx=4*UR1#X1 "Cߜ;iG1%&A rFv5 չZ :=bbU*Q4 :EtC al\&=xYp )}1{CDPA9R~(H͑"K fT܌)_:>vlȔ¨zMy݌3!EEFҏ ˿񔌝d|<)_=?ooCN 0j~~?7fkx~l [~?U͙62'&f {i;h :-C[y,؋[mvֿVV7@7o9ACÃ!*m(݋8{f]%*wD ?{~˫ޯ |ͅ.- ȈUثbL D*Yk=`b Z  T 65B8l7AoB/*ӵ(PyqfD3E4Q7a! SЀ*Wj/hSߘxo c}<ؐ&QS 4厓>r։(aTL.d:@PZө}H3 鏄6-Ayђ%nPsG0Q-C_F vQ:v 8V>_IpoD̝A+~(++\cU 4NJf[@%&A9bg}Jfgeq@H]g=;9}z<~;98}#\>yu7ӣ fs1Dv ݓ'ǻ'O0һG'G{G?xzӧO4wF z8sE(shs==&QCP" 7ge@\Ř%A)I(*}qd}zvKlRCQ #? SP%+b+HkZЙ ",)(Mcݮb Fh!Acp r)-]'nj8 +@*ũm>`@m u8Q*

    When I run the diagnosis.php file, I get:
    OK PHP: 5.3.21
    OK Hostname: DS1512
    OK Zend: 3.3
    OK OS: LINUX DS1512 3.2.30 #3211 SMP TUE APR 16 20:02:31 CST 2013 X86_64
    OK WEB Server: Apache/2.2.23 (Unix)
    ScriptCase Devel: 7.0.015
    ScriptCase Build: 10
    ScriptCase Prod: 7.0.015
    Problem COM
    Problem DB2
    Problem InterBase
    Problem Ifx
    Problem Informix
    Problem MsSQL Server
    Problem MsSQL Server SRV
    OK MySQL
    Problem ODBC
    Problem Oracle 8
    Problem Oracle
    OK PostGreSQL
    OK SQLite
    Problem SyBase
    OK PDO PostGreSQL
    OK PDO SQLite
    Problem PDO MsSQL Server
    Problem PDO Oracle
    Problem PDO Firebird
    Problem PDO Informix
    OK GD
    Environment 2
    Problem php.ini PATH:
    OK zend_optimizer.license_path: /volume1/web/scriptcase/conf - scriptcase.nm
    %09%1C%0CHl%00%86%5E%3B%F2%CB%DA%8C%B44%DD%CF%7F%E 9%89%FD%F5%FD%EC%89-EpK%1D%2B%DB%5D%26%28%03qC%2F%
    10%C3Q%E8%ADx%60+n%AF%E2%0C%EE5%F8J%8A%E9%AF7%0AA% 7F%C0%EF%CBA%10QC%8C%91%FE%400%AA%CA%E8%27f%A1%19%
    1E%13%B5%26%D7%CD%F5%8B%8EF3%3FFo%81%91%EC%FE%1D%8 41%7E%96Z%D6%93%40%B0b%F4%FCc%E3%29%9AUP%B3%F8%B6%
    DC%5Dh%A0%0B%0AX%87%FF%CD%1C%3A%8F%B2%A9%D5%AB%BAj v%E9%FEsD%BAo_%0Di%9Est%FB%A8%5E%82m%9B%2FW%1B%87%
    CA.%9B%25X%24%C7%98%BBU%C4%2C%B3%8E%D9%F8%E5%88u%8 A%03%21%E5%FB%13Y%7E%80%98%18%BDM%BC-A%E3M%C7%84%D
    OK ScriptCase write permission
    Problem Session write permission
    OK Internet Access - Socks
    Problem ZendId execute Permission
    OK ZendId MD5: f668969b5befdbf7a8fceba8886c7342
    OK Popup: Erro
    OK GD - 2.0
    OK /volume1/web/scriptcase

  • #2
    A nas is usually not a full linux system, because for example a part of the kernel can be write-protected. I would not pursue further and take a real webserver.
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)


    • #3
      It depends. I.e. Synology delivers it's nas with full php/mysql and packages. So this engine is supposed to be able to host websites. So actually the idea is not that bad. But besides that, most NAS will not have enough processorpower to run the stuff I think.
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development /


      • #4
        My NAS is a Synology 1512+ which uses an Intel core2 2.16GHz processor. It's a full featured NAS which has all the abilities of a standard Linux (like Ubuntu) options. I think there may be an extension that's not loaded or possible a configuration that is not set properly. I have attached a screenshot of the diagnosis.php result.


        • #5
          I sugest you put some questions on the synology forum. I realy don't know how to modify that, but you'll find a lot of technicians there.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development


          • #6
            I would start by trying to set up php.ini path.

            Bernhard Bernsmann


            • #7

              Are you referring to adding zend_optimizer.license_path = into the php.ini? Or is there some other path that needs to be created?

              I managed to fix the session write permission problem. Now it appears that there are two problem areas that are reparted by the diagnosis.php script. One is the php.ini PATH and the other is the ZendId execute Permission.

              Albert, the Diagnosis.php script file is part if the scriptcase installation and not something from Synology.

              Im still plugging away at this and hopefully i can get it working. Once I do, I will publish the instructions on how to do this on the Synology NAS which can hopefully help others as well as maybe other NAS's


              Last edited by pauldev; 06-18-2013, 10:35 AM.


              • #8

                Usually the path to php.ini is set automatically. Try searching on how you can set php.ini path.

                Maybe this can help you:


                • #9

                  When I run the diagnosis.php script from the scriptcase install directory, I have 2 errors under the Environment 2 section that may be causing the issues I have with getting Scriptcase to perform the initial configuration. Is there a configuration file in the scriptcase directory that will solve this problem? The two errors are: php.ini PATH and ZendId Execute Permission. Since both these errors are being reported by the diagnosis.php script from scriptcase, i was wondering if there is a way to isolate why I am getting these errors.

                  Thanks in advance.



                  • #10
                    Hello Paul,

                    There is no such configuration file. You could try to delete your current ScriptCase folder (I'm assuming here that you don't have any project - Do not delete if you do), and then extract SC again to your Web Environment.

                    I recommend you to contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                    Bernhard Bernsmann


                    • #11
                      I managed to get the scriptcase diagnosis.php script to show all green check marks. I still have a problem with the initial page loading where there is no login box. Only garbage characters on the screen. Has anyone else seen this problem?




                      • #12

                        Try contacting our support team. Is your Zend Loader working properly?

                        Bernhard Bernsmann


                        • #13

                          I have an open ticket in for this issue. Could the problem be related to the following line from the diagnosis.php output:
                          zend_optimizer.license_path: SEM ARQUIVO

                          Just curious.



                          • #14
                            Hello Paul,

                            It could be! I remember back when I worked at SC support fixing a issue related to zend_optimizer.license_path (but unfortunately I don't have access to the support db). Please mention this on your ticket.

                            Bernhard Bernsmann