Announcement

Collapse
No announcement yet.

Unbuntu Server, first run full deployment connection to mysql not saved

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unbuntu Server, first run full deployment connection to mysql not saved

    Dear Sir/Madam:

    I am fairly new to scriptcase deployment on a local server. The local server was installed with Unbuntu server, apache and mySQl. A colleague and I made a full deployment of our project. and we have successfully unzipped the deployment on our servers /var/www. we were able to create the mysql database via phpmyadmin and import all tables from the live data.All went well.

    As expect we are required to make a new connection. So we log in using the default password and asked to supply a new password before proceeding to the making the connection. So we put in the necessary fields and tested the connection again all checked out. But after we log out and try to launch the application we are again taken back to the prompt to make a new connection. We tried it using different browsers and even checked the permissions for the folder where we unzipped the deployment. But we can not seem to create a connection even though we have successfully saved one already. And we dont get any kind of error to prompt us if there are anything wrong with the connection we made. Which really puzzles us.

    Kindly point us to the right solution to this issue we are having. We shall appreciate people from this forum can help us.

    Best regards,

    Irabelle

  • #2
    Which version of SC are you running? I'm not quite sure for V7 but for V6 you need some zend-stuff to have installed. But to shorten time I would recommend to contact SC support by chat to help you out.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Make sure your top level permissions are 777 and it is recursive

      Kevin

      Comment


      • #4
        Kevin, I don't think that it would be wise to give all directories 777.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Doesn't mean that much for me
          All of my stuff is intranet only

          Might be just the _lib that needs 777

          Kev

          Comment


          • #6
            Dear Mr. Drent. we only want to install the deployed project on the production server. and we have also tried giving read, write and execute permission on the _lib directory but we are still not able to let the connection we made stay saved. we have made several deployment on a third party webhost and we did not have this problem before. This is the first time we are installing on a local server over local area network.

            we have developed the application/project using SC7. and we are constantly updating our SC7 development environment to make sure we have the latest.

            Best regards,

            Ira belle
            Last edited by my_irabelle; 07-08-2013, 02:45 AM. Reason: forgot to give the versin of SC we are using

            Comment


            • #7
              I don't have knowledge about all Linux distro's. I run several applications w.o. problems on Linux hosters. It also runs well on my Windows 2008 server. So I think there's something missing, but best approach would be to contact SC official support. I would prefer the live-chat to help you out.

              I don't know how you deployed, I prefer the following:

              - install any wamp installation on your local machine if yoiu run SC locally (we use wamp in our dev environment),otherwise install it on your dev. engine.
              - use SC to deploy directly to your wamp installation (deployment goes much faster that way)
              - test your app on your local wamp installation (if there's something wrong in your deployment, you'll notice it here)
              - use filezilla or similar to upload your full application into production (it also allows you to upload only changed files which we prefer above depl. from SC)
              - run your app in production. If things are now not working then there something on your production site like Zend, access rights etc. Sometimes changing rights is prohibited as apache would be the owner in stead of the user (depending on provider). But at least it will give you info if it's SC or server settings. After all, it's 'just' php.

              Hope this helps (a little)
              Last edited by aducom; 07-08-2013, 03:01 AM.
              Albert Drent
              aducom software netherlands
              scriptcase partner, reseller, support and (turn-key) development
              www.scriptcase.eu / www.scriptcase.nl

              Comment


              • #8
                our online support already expired. we have already tried what you were suggesting. we are developing using cloud server with CENTOS and phpmyadmin. all deployment prior to the local server one, on installation no issue what soever. And every deployment went well, full or selected deployment.

                but can you give me a list of "application" needed to run the app in production. you keep mentioning Zend, i thought this was needed only on the SC development. is this Zend gaurd or server? We can try and install this.

                also do you recommend that we install gui for unbuntu or just stick to using the command line. this is really new to us.

                thank you so much for the help.

                Comment


                • #9
                  From: http://www.scriptcase.net/scriptcase-faq/

                  What are the requirements to run ScriptCase?

                  A web server (Apache, IIS, Sambar, Abyss, PWS, Xitami, etc) enabled to run PHP Scripts and Zend Guard Loader.

                  Hope this helps...
                  Albert Drent
                  aducom software netherlands
                  scriptcase partner, reseller, support and (turn-key) development
                  www.scriptcase.eu / www.scriptcase.nl

                  Comment


                  • #10
                    super thanks mr. drent. appreciate it. will install some of software you listed. have a nice day

                    Comment


                    • #11
                      I know this thread hasn't seen an update in a while, but as I have the exact same issue (SC7 production deployment on a Ubuntu server) I was wondering if this has been resolved, and if yes, how?

                      thanks in advance,
                      Volker

                      Comment


                      • #12
                        Have you tried to setup things with your _lib and subdirs set to 777? Most of the time, if the config cannot be saved, it's a rights issue. After setting your connection you need to go back to 644.
                        Albert Drent
                        aducom software netherlands
                        scriptcase partner, reseller, support and (turn-key) development
                        www.scriptcase.eu / www.scriptcase.nl

                        Comment

                        Working...
                        X