Announcement

Collapse
No announcement yet.

prod-Server php.ini-path not set

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • prod-Server php.ini-path not set

    Hello,
    can anyone give me a hint, how to solve this:
    the diagnostics run on the prod-server tells my, that the php.ini-path is empty.
    I want to set it correctly, so that I can in the next step set the seesion_write permission, which also is not set.

    Any help is gratefully welcome.

    Thanks.

  • #2
    what kind of production server are you running? On a service provider, your own virtual/dedicated server, windows/linux etc? If you install things from a wamp package (i.e. uniform, wamp, xamp and others things are useually set by default).
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Hi,
      I run a vritual root-server by Strato, Ubuntu Linux on it
      I installed the prod via ftp and via zip-files.
      Both show exactly the same result, behaviour and diagnostic results.

      There three things shown negativ: php.ini-path is empty, session_write_permission is off (some on mac-system which I use for develpment with sc7-installation-server), zendid is off.
      The first grids show up correctly, but the pdf-export does not work.

      Comment


      • #4
        Originally posted by hoko View Post
        The first grids show up correctly, but the pdf-export does not work.
        Set the permission for files in _lib/prod_third/wkhtmltopdf to 755 and try again.
        Best regards: - Reinhard -

        I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

        Comment


        • #5
          Originally posted by RHS View Post
          Set the permission for files in _lib/prod_third/wkhtmltopdf to 755 and try again.
          Checked that, is ok.
          But even with 777 no success.

          Comment


          • #6
            Originally posted by hoko View Post
            There three things shown negativ: php.ini-path is empty
            Ok, look first at Strato FAQ and edit your php.ini: Click!
            Best regards: - Reinhard -

            I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

            Comment


            • #7
              thanks for trying to help. I know the location for the php.ini, the question is: why does sc7-diagnostic stat php.ini-path empty.

              Have'nt I do change settings in sc to make path visible?

              Comment


              • #8
                Hi,
                I have the same problem: on my production environment diagnosis.php does not show the php.ini file. I know the location, but how can I configure this in scriptcase?
                My production environment is a synology with DSM 6.x (linux 64 bit, apache 2.4.27, PHP 7.0.21).

                Additionaly diagnosis.php shows, that zend.id execution permision is deactivated. Is this for production needed?

                I tried to run some applications created with SC. I works almost. But not grid applications with nested grids (master - detail): in this applications the functionality is given, but only in plain text (no theme is working (I tried different theme, but nothing helps)).

                Has someone an idea, how to solve this problem?

                Comment

                Working...
                X