No announcement yet.

[SOLVED] How to disable ZendGuardLoader in App wrote in SC 7.1

  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] How to disable ZendGuardLoader in App wrote in SC 7.1


    Where to find good working HOWTO for Linux (Gentoo) and PHP 5.3? I tried to install SC 7.1 and should install (as requirements). Could I disable ZendGuardLoader ?? I don't need it.

  • #2
    You do need it if you want to run Scriptcase. The IDE is precompiled in Zend.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development /


    • #3

      But should I have Zend Guard Loader client's server where I am going to deploy applications?


      • #4
        Hi daretzki,
        I am a SC user... just like Albert said, you only need Zend installed on your PHP server if you are going to run Scriptcase IDE itself . You can deploy to any website with PHP... no need to worry about the Zend. On my host server, I have a choice what PHP version I use, etc. I have also done the zend install many times in Linux now, for the IDE part.

        In case you really want to run the SC IDE up there, I am going to paste my general process checklist below. I run SC6, SC7.1 , as well as development test sites for my apps, up on a hosted server.

        1) check if your hosting server is 32 BIT or 64 BIT. Different version of zend needed - mine was 32 as below, not 64 bit

        2) a helpful post:

        3) created a new server application folder/website, using php5.3 (if you use other PHP version, get the proper downloads below)

        4) log into your host using SSH - do following steps (assumes you have made the new website in a folder named XXyourfolderXX, on your account name YYyouraccountYY)

        cd XXyourfolderXX


        tar -zxvf ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz

        mkdir cgi-bin

        cp ZendGuardLoader-php-5.3-linux-glibc23-i386/php-5.3.x/ cgi-bin/

        touch php.ini

        nano php.ini
        (put the following in that php.ini file)
        zend_extension = /home/YYyouraccountYY/webapps/XXyourfolderXX/cgi-bin/
        zend_loader.enable = 1

        rm ZendGuardLoader-php-5.3-linux-glibc23-i386 -R

        rm ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz

        5) when you run SC7.1 you will have to go thru an install process. It tells you with a diagnostic screen if the zend is working properly or not.

        I have done this several times and you have to be careful about getting the correct version and bit version that matches your setup. Once it works, it just works

        Good luck!


        • #5
          Hi Jamie and Albert,

          Great. Thanks for your great support.
          Please close thread.