Announcement

Collapse
No announcement yet.

Install Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install Issue

    Hi there,

    I have downloaded the Scriptcase 7.1 zip (scriptcase-7.1.014-53-en_us.zip) from the Scriptcase website and uploaded and extracted it to our Plesk webserver. I have set all file permissions to 755 as per the installation instructions.

    When I navigate to the address to begin the install I get the following message...

    "This Scriptcase is encrypted for a different version of php.
    Your PHP version is 5.3.27, please check the tutorial to learn how to update your php.
    Or download the version of Scriptcase appropriate for your environment."

    I stated above our server is running PHP 5.3.27.

    Does anybody have any ideas why this is not working.

    Thanks,



    Mike

  • #2
    Originally posted by mikew View Post
    I stated above our server is running PHP 5.3.27.
    Use PHP 5.4.x
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

    Comment


    • #3
      I'm confused; Why would the install zip for PHP 5.3 be expecting to be run on PHP 5.4?

      Comment


      • #4
        Hi Guys,

        As an update... it was the Zend Guard Loader extension which was not enabled on our Plesk VPS. I have instructed our hosting company to enable this and it is all working correctly now.

        Cheers,




        Mike

        Comment


        • #5
          Originally posted by mikew View Post
          I'm confused;
          Ah, sorry, i have not seen that (scriptcase-7.1.014-53-en_us.zip) .014 is actually for PHP 5.4.
          Best regards: - Reinhard -

          I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

          Comment


          • #6
            Hi There,

            As an update we are still having problems with our hosted version of Scriptcase 7, so I have a few questions as we seem to be getting various error messages all over the place. We are running on a Plesk 11 VPS / Centos. I have attached the diagnosis file as I was hoping that any other users that may have a similar setup running successfully could give me some pointers on how to get this working?

            1) Should I be running the Scriptcase development environment as Apache Module or Fast_CGI?
            2) What list of IP addresses / ports does Scriptcase call out to? So far I have had to allow the following exceptions to the Plesk firewall... 54.225.241.189 & 54.225.96.12 both on port 80, but the Plesk error logging seems far from ideal so I have to contact our ISP as problems arise which is far from ideal.
            3) Does Netmake provide a more detailed list of system requirements & settings for running Scriptcase in a hosted environment and if so, could someone provide me with this?

            Lastly, I have noticed that the diagnosis page is showing an invalid path for php.ini. I'm talking to our hosting company about this at the moment, but could this be significant?

            Thanks,



            Mike
            Attached Files

            Comment


            • #7
              As a further update the error (not always the same script, but the same fclose error) that we seem to be getting most consistently is the following...

              fclose() expects parameter 1 to be resource, boolean given | Script: /var/www/vhosts/tsm-ltd.co.uk/subdomains/dev/httpdocs/scriptcase7/devel/lib/php/functions2.inc.php linha: 402

              Thanks,



              Mike

              Comment


              • #8
                Hello Mike,

                I recommend you to get in touch with our support team. If your support is inactive, please contact us as a Trial user.

                regards,
                Bernhard Bernsmann

                Comment


                • #9
                  Hi Bernhard,

                  Thanks for your reply. I finally got it working!

                  It seems that the problem was that we were trying to install Scriptcase to a subdomain. I have registered a separate domain name and deployed Scriptcase to this and it all seems to work perfectly now.

                  In case it is of any use to others here is our working configuration for Scriptcase 6 and 7.1 hosted on Centos / Plesk 11. These are the options that I had to change over and above our hosting companies default Plesk PHP domain settings.

                  PHP running as FastCGI.
                  memory_limit: 150M
                  safe_mode: off
                  session.save_path: /tmp
                  open_basedir: none
                  file_uploads: on

                  I also had to allow the following IP addresses to make outbound connections on tcp port 80 in the Plesk firewall...

                  54.225.241.189
                  54.225.96.12

                  The only part that does not seem to work is the "Show Diagram" option, which fails to produce a valid image; I'm not too concerned about this, but would be interested to here if anyone has a solution...

                  Lastly, with regard to the support, we used to have Scriptcase support, but decided not to renew this time as most of the replies that we received to our support issues were in very broken English and for the most part we simply couldn't understand them. We would happily pay for support if we felt that we would get the answers to our questions, but unfortunately our previous experience has put us off.

                  It's a shame because Scriptcase is such a good product, but it is a little let down by the support and documentation.

                  Thanks,



                  Mike

                  Comment

                  Working...
                  X