Announcement

Collapse
No announcement yet.

SC installation in shared host (JustHost)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SC installation in shared host (JustHost)

    Dear all,

    i need help here: http://sc.astudion.com/devel/iface/login.php

    i am not able to proceed with my installation of SC and i donot wht's went wrong.
    i was following the steps
    http://www.scriptcase.net/install-sc...2&conv=3&ln=en

    And i hav clarified with JustHost.com, the requirements are full filled
    Requirements:
    Web Server with PHP support, such as Apache, IIS
    PHP 5.4 with the modules mbstring, GD2 and zip enabled
    Zend Loader
    SQL Database (SQLite, MySQL, MSSQL, PostgreSQL, Oracle or DB2) PHP accessible .

    How to get it resolve?

    Thanks

  • #2
    hope really get some input since i already spending hours looking for possible solution but i hv totally no clue
    Attached Files
    Last edited by weilies; 06-29-2014, 01:23 PM.

    Comment


    • #3
      Hi weilies,
      Just another user here, so I am just adding encouragement. I have SC running on a similar setup so it can be done for sure. When I go to that URL I see the initialization screen, BUT it is not showing images and is inoperable.

      I had a problem with installing on PHP5.4. What I did was create a PHP5.3 static site on my host, then did the whole SC steps on it. Maybe that will help you - it did the trick for me. I never spent the time to figure out what was happening, as it doesn't seem to make a difference to SC functionality to be on PHP5.3.

      Anyway, also look out for the following too - things I had glitches at first:
      -- using php5.3, make sure you get the ZEND Guard loader that matches the PHP version - the steps below got me the right one

      wget http://downloads.zend.com/guard/5.5....23-i386.tar.gz

      tar -zxvf ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz

      mkdir cgi-bin

      cp ZendGuardLoader-php-5.3-linux-glibc23-i386/php-5.3.x/ZendGuardLoader.so cgi-bin/

      touch php.ini
      nano pnp.ini
      zend_extension = /home/YOURACCOUNT/webapps/scide753/cgi-bin/ZendGuardLoader.so
      zend_loader.enable = 1


      rm ZendGuardLoader-php-5.3-linux-glibc23-i386 -R

      rm ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz

      Oh yeah, check with your host about the 32 verses 64 bit version the OS is on - the above worked for me as the server I am on is 32 Bit.
      Not sure is any of that fixes your issue directly or not, but worth a try.

      making and running a test.php file in your root folder of your SC install might also help you see the issues:
      <?php

      // Show all information, defaults to INFO_ALL
      phpinfo();

      ?>



      Support can help you as well - or maybe someone tomorrow (Monday) will see your forum post and know specifically what is going on. Again, stick with it and you will get it working
      Peace,
      Jamie

      Comment


      • #4
        hi Jamie,

        Thanks for your help and it's now working!
        http://sc.astudion.com/<folder_name>
        it couldn't be directly paste into domain/sub domain but MUST be inside a <folder>
        in my case, i use http://sc.astudion.com/<folder_name> and it jz working fine!

        now it's time to scriptcasing!

        Comment


        • #5
          Congratulations! That is a good feeling when it works. Be sure to keep a log of every step you took to get it installed for future reference. Also make sure you make backups of your SC projects using the SC backup tools.
          Peace,
          Jamie

          Comment

          Working...
          X