Announcement

Collapse
No announcement yet.

[SOLVED] Filename issue on Document (database) and Document (Filename)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Filename issue on Document (database) and Document (Filename)

    On Document (database) and Document (Filename), it doesn't accept filename with spaces or multiple dots (ie apple.1.1.2.pdf)

    Also in Document (database) , even though I have a mediumblob field (which i expect it can store a 16mb data), i can't upload a file over 4mb.

    I have the latest scriptcase version.

    Dear Scriptcase please fix it asap, i am rushing for an online form contains some upload fields.

  • #2
    Max file size see here: http://stackoverflow.com/questions/2...load-file-size that solves one issue.
    The other one smells like a bug...

    Comment


    • #3
      Hello,

      I didn't simulate this problem testing locally. Whats charset are you using?
      Best Regards,
      John L. Santos

      Bug Tracker Team
      NetMake - IT Solutions

      Comment


      • #4
        Dear rr and John, Thank you for your reply.

        I spent a hour to figure out what is going on and finally know what causes the bug.

        say 2 files, both with double-byte character filename:
        file 1) 測試a . b . c.pdf
        file 2) 測a . b . c試.pdf

        while file 1 works on all document/image filename/database but file 2 failed all.
        you can see that if the spaces or symbols appear between the 2 chinese words, that caused the problem.
        This problem happens on both image/document filename/database fields.

        I hope this can be fixed in the upcoming scriptcase update. Thank you very much.

        Comment


        • #5
          It doesn't have to be some complicated chinese multibyte character. A simple accented letter with a code above 128 is also enough to make a document (filename) upload fail. This wasn't the case in earlier versions.

          Comment


          • #6
            Probably on windows servers. Many uploaders fail on windows (e.g. jqueryupload) when strange characters are there. So are you on linux or on windows?
            I guess this happens on your windows server, that would make sense. Does it happen on a deployed linux?
            Last edited by rr; 11-24-2015, 07:57 AM.

            Comment


            • #7
              It happens on the deployed app on the linux webserver. Not on the development-server running windows. I get a Upload failed message/alert, when running the app on the linux server. Never saw that in earlier versions.

              Comment


              • #8
                Under which filesystem is that linux running? And more important, which encoding does it have? I am not a pro in this area but I noticed filename encodings can go wrong on various filename encoding settings. Your linux filesystem is for example in UTF-8 but it may also be in a different. This may cause this..
                See http://mindspill.net/computing/linux...cter-encoding/ for details, there is more info on google if you search a bit.
                Also (even more) important is to know on which characterset your mysql is and if you have your database connection set to the same characterset or not. My easy solution is always to set the database, the website and preferably (if possible, often this isnt needed) the filesystem, to the same characterset.
                So now you do get back to John L Santos his reply. Please check the characterset settings.

                Comment


                • #9
                  The Linux server runs UTF8. With a previous version of SC it worked fine. After the latest update not. Charsets have not been changed. SC is an (extremely) buggy program.

                  Comment


                  • #10
                    Originally posted by wowwow9 View Post
                    Dear rr and John, Thank you for your reply.

                    I spent a hour to figure out what is going on and finally know what causes the bug.

                    say 2 files, both with double-byte character filename:
                    file 1) 測試a . b . c.pdf
                    file 2) 測a . b . c試.pdf

                    while file 1 works on all document/image filename/database but file 2 failed all.
                    you can see that if the spaces or symbols appear between the 2 chinese words, that caused the problem.
                    This problem happens on both image/document filename/database fields.

                    I hope this can be fixed in the upcoming scriptcase update. Thank you very much.
                    First I did some testing with Windows, check this images. I'll try to check in Linux, but as rr said, you need to check the character used in your operating system.
                    Best Regards,
                    John L. Santos

                    Bug Tracker Team
                    NetMake - IT Solutions

                    Comment


                    • #11
                      Charsets only deal with the presentation. With what you see on the screen. Charsets do not cause error-messages to be shown on the screen. That's been done by SC-magicians in Brazil.

                      Comment


                      • #12
                        Originally posted by John L. Santos View Post

                        First I did some testing with Windows, check this images. I'll try to check in Linux, but as rr said, you need to check the character used in your operating system.
                        I am running this on my local win7 pc. win 7 is unicode but im using traditional chinese as the default language. my mysql is using utf8 and same as the tables.

                        i wish i can upload a video to here.

                        Comment


                        • #13
                          Originally posted by wowwow9 View Post
                          i wish i can upload a video to here.
                          Upload a video to youtube, vimeo or ... and post the link ...
                          Best regards: - Reinhard -

                          I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                          Comment


                          • #14
                            I've spent another hour to play arround win7's language options. I finally found out that under Control Panel > Regoin and Language > Administrative > Language for non-Unicode programs. I changed it to English and it solved the case.

                            and the other issue that about uploading large size file, i fixed it by changing the value of max_packet_allowed in mysql setting.

                            Comment


                            • #15
                              Originally posted by wowwow9 View Post
                              I've spent another hour to play arround win7's language options. I finally found out that under Control Panel > Regoin and Language > Administrative > Language for non-Unicode programs. I changed it to English and it solved the case.

                              and the other issue that about uploading large size file, i fixed it by changing the value of max_packet_allowed in mysql setting.
                              Hello,

                              Very good! I was thinking about a remote access to check the problem, but I believe it was solved. (:
                              Best Regards,
                              John L. Santos

                              Bug Tracker Team
                              NetMake - IT Solutions

                              Comment

                              Working...
                              X