Announcement

Collapse
No announcement yet.

Errors in IDE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors in IDE

    I keep getting these error messages within an SC IDE. Any ideas ?

    IDE_errors_MapApi.jpg




    IDE_Errors7.jpg
    -----------------------------------------
    Arthur Klisiewicz
    dATA POINT SOFTWARE
    www.datapointsoftware.com

  • #2
    I has same error in previous version SC. I reported this error but without answers of forum.

    Comment


    • #3
      Hello,

      We can't simulate the problem.
      Please, send this application to us. send to email: bugs@scriptcase.net

      --
      Best regard,
      Netmake team

      Comment


      • #4
        Artur - my project has about 180 Apps and just the backup takes about 50Mb. You do not expect me to email it - do you ? No email server can handle such big files.
        -----------------------------------------
        Arthur Klisiewicz
        dATA POINT SOFTWARE
        www.datapointsoftware.com

        Comment


        • #5
          Hello,

          I just need one application to simulate the problem, is not necessary send the project.
          The scriptcase have the option to export only one application.
          Go to menu project > Export applications
          And export the dump of create table.

          --
          best regard,
          Netmake team

          Comment


          • #6
            I noticed that the errors are related to all Apps which have dropdown field (selection). All the apps throughout the project that show AJAX based content now show nothing.
            Basically 80% of the forms got screwed up (and it was working perfectly fine until I updated SC to v8.1.020).

            when I lookup the error it shows this:

            Undefined offset: 6 | Script: C:\Program Files\NetMake\v8\wwwroot\scriptcase\devel\lib\php\ functions.inc.php linha: 2373
            so obviously it is related to the PHP library, but the PHP file is obfuscated (which drives me nuts) and I cannot even get a qild guess why is it happening.
            I have send the App to the Email given bugs@scriptcase.net
            bust so far haven't herd anything yet. The bugs and errors can be basically divided int to two categories: Critical and NonCritical. This basically prevents me from any work because all Ajax procedures stopped working and I cannot even test existing Apps.

            I exported grid/form Apps then re-imported to the new project. Same errors, and same functionality is missing.

            UPDATE:
            ============

            I created 2 new apps (grid/form) and when I select DROPDOWN type for the field (SC calls it Select) the same errors appear in IDE. The bottom line - something is really wrong with "Select". I was able to create Ajax dependable 2 dropdown lists and it seems to work but the errors in IDE simply show something is wrong, beside my curent project is still completely screwed up.

            My SC version 8.1.022
            Last edited by aka; 01-13-2016, 08:38 PM.
            -----------------------------------------
            Arthur Klisiewicz
            dATA POINT SOFTWARE
            www.datapointsoftware.com

            Comment


            • #7
              I did some testing creating new forms and it looks like the Ajax update and SELECT field works fine with new forms, but all forms from my old project have lost this functionality after upgrading to v8.1.22

              ARTHUR
              Last edited by aka; 01-14-2016, 11:10 PM.
              -----------------------------------------
              Arthur Klisiewicz
              dATA POINT SOFTWARE
              www.datapointsoftware.com

              Comment


              • #8
                UPDATE
                This is an update to the last post. Unfortunately even when creating new Apps I still get similar errors. Now they appear in grid App. Since I have so many issues after upgrading to SC 8.1.020 (SC did not want to run at all). Perhaps this might be related to the OS. At this moment I'm running SC v8.1.022 + WindowsXP/SP3 and using FIREFOX v43.0.4

                I wonder if anybody else is successfully using SC in this configuration (as it is not working for me at all) ???
                -----------------------------------------
                Arthur Klisiewicz
                dATA POINT SOFTWARE
                www.datapointsoftware.com

                Comment

                Working...
                X