Announcement

Collapse
No announcement yet.

[SOLVED] Please solve the problem version 8.1.040 Ajax event not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Please solve the problem version 8.1.040 Ajax event not working

    After updating to version 8.1.040 is not working ajax event to fill in the text field.


    this query on Ajax Event that used to work does not work now:
    $query="SELECT mu.codice, mu.codfurgdefault FROM mio_utenti mu
    WHERE mu.codice={CodOperatore}";
    sc_lookup(dataset,$query);
    {CodMagazzinoMobile}={dataset[0][1]};

    Last edited by kkkpe; 05-20-2016, 04:48 AM.

  • #2
    Wich type of application? Wich event? I did a quick test and work as expected with this code.

    Control App. onBlur event.
    PHP Code:
    $qry 'SELECT name from products WHERE id=' . {a};
    sc_lookup(arr_prod$qry);

    {
    b} = {arr_prod[0][0]}; 
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      even with your syntax does not work.

      Comment


      • #4
        Wich type of application? Wich event? Are you sure your qry returns data? Did you tried to debug vars and final qry?
        /Giuseppe

        Professional Scriptcase Services
        Some Customers opinions

        Comment


        • #5
          understood the problem. After updating to version 8.1.040.
          l 'ajax event of a FORM does not assign the value to a select type field.
          Last edited by kkkpe; 05-20-2016, 04:30 PM.

          Comment


          • #6
            Hello,

            It is very probable that the fix for this false problem also solve any issues related to Ajax events.
            http://www.scriptcase.net/forum/foru...ndefined-flase
            Best Regards,
            John L. Santos

            Bug Tracker Team
            NetMake - IT Solutions

            Comment


            • #7
              could you please update as soon as the false error ??

              Comment


              • #8
                Hello,

                Please, update your ScriptCase to release 8.1.041 and let us know if the problem persists.
                Best Regards,
                John L. Santos

                Bug Tracker Team
                NetMake - IT Solutions

                Comment


                • #9
                  Hi.

                  I am having similar problems text auto-complete (ajax events) where other fields are not being filled in based on input. I am version 8.1.041. Older forms are still working perfectly. Those created in 8.1.040 not working.

                  Rgrds

                  Moh.

                  Comment


                  • #10
                    Hallo Again,

                    Kindly note that this problem is resolved.

                    Matter of fact it was (in my case) field reference wrong spelling; {ptrans_item_id} instead of {prtrans_item_id} which was obviously returning empty dataset.

                    My sincere apologies.

                    Rgrds

                    Moh.

                    Comment

                    Working...
                    X