No announcement yet.

ScriptCase 8 - Bugs

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by itsme3 View Post
    Thanks for your reply and care dude, there are few concepts in life which i hate, one of them when someone says "I'm busy" I believe there is time management, and "priority" hence "I'm busy" can be used only if you didn't plan well, but that is my opinion anyway ...
    I agree with you completely.

    @Netmake: if you could offer free professional versions for community, we could maintain bugs, forum, knowledge base etc for you. I need to make a money with tool like SC, i haven't interest to spent whole day/days for workarounds etc. But pay attention on the fact, that community spent a lot of time for bugs reporting and you don't do not repair them. You release new versions of the SC in which errors are duplicated from previous versions. Community pays a lot for the use of tools which has let us make money. This is not an open source project and do not understand the translation, you do not have the time. If you do not have time please stop work on new SC version and correct previous.

    I think that is a time for serious discussion about new version, what community (your bussiness clients) need, about licencing, and how you could help community to make a money. Last time I spent 3 days for find workaround for problem with Form->Master/Detail -> Form. Its core functionality. It is not working. Sometimes i see correct buttons/ sometime not. Modal window working but form editable grid are not refreshed etc etc etc etc ! There is a lot of issues, a lot of guys wrote about it on forum and .... nothing.... new SC version with not important changes and old bugs. I wonder if not abandon projects created in the SC because I can not meet the deadlines agreed with the customers due to errors and workaround searching etc. I can't make a money.

    Guys! What with you ?

    daretzki (Darek)


    • #92
      en formulario campo etiqueta no funciona / Label field does not work in form

      SC8.4 - Form - marco campo como etiqueta (solo lectura) e igual puedo ingresar el dato para Agregar. Tampoco funciona la opción Deshabilitar campo.

      SC8.4 - Form - selected Label field (read only) and the same can input the data to add. Field Disable Neither option works.
      Attached Files


      • #93

        Did anyone see this??

        Thanks for your reply!!



        • #94
          Alignment of language and/or theme selection in menu application does not have any effect. It's always centred.
          Language and/or theme selection doesn't show up in mobile menue.
          Unable to save changes in advanced theme editor. It hangs on clicking the save button. I have to close browser tab/window.



          • #95
            SCRIPTCASE 8 - Grid and 'Columns' and 'Sorting order' buttons from the toolbar.

            Scriptcase Version 8.00.0004

            If a grid starts showing as initial module the search module,
            the 'Columns' button and 'Sorting order' button from the toolbar
            do not act when you click them.

            (If the grid starts showing as initial module the grid module,
            the 'Columns' and 'Sortting order' buttons work).

            Professional applications usually require to start grids
            with a search before starting to display records
            (for example big tables of invoces, products, people...).


            • #96
              Hi! There is a BUG BIG the layout page and block do not function on tab function,
              test with two page and on second page put 2 o 3 tabs with fields the result is a strange positioning of data.


              • #97
                Originally posted by dcputernut View Post
                We bought this software so that when we developed our application we would be developing for Mobile too.
                In SC7 I had created a quickie project and the forms looked fine in Mobile (OS and android)

                #1 After getting SC8 the Registration page I created, shows NONE of the fields show on mobile I have onApplicationInit (sc_apl_conf("Registration", "start", "new").
                the only way to get the page to load the fields on mobile is to touch the "Add New" button at bottom. Then the page loads with blank fields.

                issue #2 - NewItem page, I have the same onApplicationInit (sc_apl_conf("NewItem", "start", "new"); Once the "Add New" button is touched the page shows the select drop downs for the first field,which should load the 2nd and 3rd field drop downs, it doesn't work at all.

                again Neither of these issues show up on PC browsers. (chrome and IE) but do on iphone and android phones

                Printscreen #1 is issue #1 pc browser, with mobile version of page next to it.

                Printscreen #2 is issue #2 pc and mobile compair.
                So there has been a couple of updates since I posted this, and the changelogs say mobile forms was addressed, but this is still an issue.

                and to add to it, since this update I can't "Deploy to server" anymore. I get an error saying "Folder : Please, inform a valid folder." but it's the same folder i have been using, and is in fact valid!

                Boy for what we paid for would think there would be better support??

                any idea if these issues will be fixed...or do I find another product?
                Last edited by dcputernut; 08-21-2014, 03:22 PM.


                • #98
                  PDF - Onrecord

                  Cómo están ?
                  Con la conversión a de v7 a V8, se perdió en el formulario pdf el evento onrecord.
                  Sin embargo, los formularios convertidos funcionan perfectamente, como si el evento existiese.
                  Alguien sabe algo al respecto?, gracias

                  How are you?
                  With the conversion to a V8 v7, was lost in the pdf form onrecord event.
                  However, the converted forms work perfectly, as if the event existed.
                  Anyone knows something about ?, thanks


                  • #99
                    @daretzki totally agree with you, but also give them sometime, me just like you and other guys we spend time for workarounds, when possible, but main functionalites that can't be changed those are what make me really upset and irritating

                    @anibal that works dear, i noticed it not being a real label, but it can't be edited... looks like editable field but it is not changable anyway, that is tiny thing to mention... FYI i tried to play with the CSS of the fields to remove the field border but dind't work... what i noticed, if the form is in edit mode, then yes, it works as real label...

                    @antonio.alcantara agree with you, the java used to select the fields in A-dynamic search B-dynamic group by C-"stupid" totalization all is not working... sometimes work in development env but never worked in production.... and what is really killing me that totalization which is set clearly NOT TO USE but keep appearing no matter what, can't be removed, can't be changed, and doesn't work, sucks!

                    @VDPVince they will need more information about your story, do you mean the tab application?

                    @dcputernut sorry to say this but they are not this fast, sometimes take months to answer, that is if they do!! that is why forums are not considered their official chanel, and if you send them an email, they may answer, but also take time... maybe because of the lack of the English language, i don't know... real problem is they don't do action to improve things... simply adding official bug tracker from their side will serve everybody! and at least the bugs can be contained and followed up correctly

                    What we need now guys is an index of all bugs of SC8, obviously they don't read what we write, they offer professional support but it is paid (not free and doesn't come with SC) - i did consider that though, but later changed my mind when i sent them an email during the free testing period and they answered after 2 months when i had the license already and using the SC normally for about a month, i strangely had a reply from them! i forgot what i sent them earlier loool. However, i think these bugs are included under "bugs", not support! so if they don't have bugs tracker, and they don't want to adopt our offers to have one in our place (like Albert Aducom and Giu offered them thankfully) and they also don't reply and care about our comments, then at least we do the last chance before giving up, lets have these stuff in this 10 pages filtered in a new thread as index with direct problems, perhaps they look at them instead of reading all the comments along, who can test and put them this way in neat!?
                    Last edited by MikeDE; 08-21-2014, 05:33 PM.


                    • I am completely and incredibly amazed that people are still buying this software
                      I use it DAILY and love it, but I stopped upgrading after version 6
                      Go back to when version 7 was released and you will see ALL the same posts

                      This company has proved they do not care about their product
                      Only their bottom line, let's put out a new version our forum will increase
                      What do they say, "There is no such thing as bad press "

                      I hope and pray a real company will buy them someday

                      Version 6 last useable release


                      • @itsme3 not works dear! the read-only field can not be changed in edit mode, that's fine; but in add new record mode can be entered, which is wrong...
                        Attached Files


                        • Originally posted by anibal View Post
                          @itsme3 not works dear! the read-only field can not be changed in edit mode, that's fine; but in add new record mode can be entered, which is wrong...
                          ok, lets sort it out, you have single record form, when making it as label = Yes, then in insert mode is just blank! i don't have even a box shape... insert mode = no value, that works ok for me

                          when in edit mode, i used "read only" from Edit fields... and it works fine.. it gives the field value as non-editable, just text withe correct value... ty removing the label field option, and keep only the read-only from edit field

                          do you have the latest version 004? did i understand your issue correctly? because in muliple-records form is also working, but when used as read-only or label field in insert mode, it does show a box border around the field but also not editable...


                          • Error using UNION,

                            I have :
                            - Data Type "Select"
                            - Lookup Settings -> SQL Select Statement using UNION
                            - it work well after compiling

                            But, If we use "Ajax Processing - Events onChange" to pass parameters to next Data Type "Select", the data show nothing, only "loading process"...

                            need Solution...or is this a bug ?


                            • SC8 Bugs quick search not working with SQL type -> text

                              Quick search not working properly
                              For example if I select one or two fields for quick search in 'Search/Quick search/Select fields', if sql type of fields is text, the quick search box disappears from the toolbar of grid application.
                              If I change in MySQL type of fields to VARCHAR and I create a new grid application and the app see now the fields like VARCHAR the quick search is working. The problem is that all my projects has fields text and in sc7 quick search worked ok with text.

                              I did some tests and I think is an error in scriptcase
                              Attached Files


                              • Originally posted by angelrobv View Post
                                I did some tests and I think is an error in scriptcase
                                Yes, but a design issue too ... If you have fields with <= 255 chars you should use VARCHAR / CHAR, not TEXT. This fieldtype use only with fields > 255 chars.
                                Best regards: - Reinhard -

                                I use ScriptCase 8 Enterprise Edition, Version 8.(latest)