Announcement

Collapse
No announcement yet.

[SOLVED] anybody has the update button work for single-record form ON MOBILE device?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] anybody has the update button work for single-record form ON MOBILE device?

    please advise your experience, lets see how many has this problem using SC8.006

    more info
    http://www.scriptcase.net/forum/show...27-2014-21-39)

  • #2
    okay, lets re-phrase

    can you guys try to use your mobile for any application that produced by SC8 that has single-form and make and update function from mobile? see if it works?

    please!! it works for me on desktop but not on mobile, tried many devices and tables, seems bug but not yet addressed

    Comment


    • #3
      Up, please guys, somebody test!? i didn't leave anything not to try, this makes me hit the wall, wanna know why nobody reported it, it is obvious, and wanna make sure it is for everyone?! there is not much to tell you that might be only from my side! just simple functionality, works ok on desktop but not on mobile device, strange!

      Comment


      • #4
        Has a link to try from my ipad?
        /Giuseppe

        Professional Scriptcase Services
        Some Customers opinions

        Comment


        • #5
          Giu, dear, my case is not working, not from any mobile, not from ipad nothing... only from Desktop, that is why i want you to test your single-form for any application that you developed using SC8 in single-form UPDATE procedure, and see if works or not... i have it an application link from a grid to update the record.. and it opens ok, and updates ok on desktop, but not on mobile, this is becoming personal and i've spent for it full week now, see this link for more info
          http://www.scriptcase.net/forum/show...27-2014-21-39)

          any idea or hint is highly appreciated

          Comment


          • #6
            I will try when. Scenario is a simple form, and modify button don't appears?
            /Giuseppe

            Professional Scriptcase Services
            Some Customers opinions

            Comment


            • #7
              it appears, and works on desktop, not on mobile!!! no response at all, just simple message "processing" and nothing else! only on mobile,.,, while works ok on desktop!!

              i tried to put simple echo command on event: onAfterUpdate but didn't work on mobile, only on desktop... there is something breaking the ajax.. .event can't validate the required fields on Update mode, no message appears that this field is required!!! but on desktop it works ok

              crazy i know, just try and see

              Comment


              • #8
                Sorry, but seems to work for me on iPad. Has you some export of the app, and SQL to recreate database?
                /Giuseppe

                Professional Scriptcase Services
                Some Customers opinions

                Comment


                • #9
                  yes, works for me on iPad too, only mobile not working, tried android S2, S3, S4 and S5 and iPhone

                  i will createfor you sample project and sql dump similar to the one i have, just give me about 1 hour please

                  Comment


                  • #10
                    Alright, I figured it out...... finally, and it is a serious bug needs to be addressed..

                    i have a field in the table name {id}, it is the auto increment field, primary and unique...

                    problem is (in all applications i usually do this practice) i just put this id field as not-shown from Edit fields > directly to not shown! i just drag it to the end of the fields in the not-shown area...cz i dont' want to display it anyway,,, then forget about it..... this works ok on desktop, but seems the mobile version can't determine the id of the record if the id field is not in the "shown fields" !!!!

                    now what i have done? i was trying single step on local network using my mobile directly on local dir on xampp localhost of the sc-installed PC... when trying to create the project for Giu to test.... i found it working!!! made analysis, the only difference between the form i have in production and the one i am making for Giu test is the id field i kept it shown normally in the test version... so i put it back into the not shown list then i found the same issue!! works on desktop but mobile version have difficulty updating the record if the id field is within the fields those not shown!!

                    don't know if it is related to ajax or something but this is defiantly annoying, nobody will include the id field in the form!! and if someone suspects his abilities will search all possibilities but will not think about this! especially that is working perfect from desktop... even if you turn on "show desktp verson" from mobile on local network u will find it working.. only mobile version doesn't work...

                    finally, i included the id field in my fields of the production application and made it as hidden from field settings, now works from mobile as well

                    you can imagine guys what i've been through the last days trying many many things and learnt a lot of stuff during these tests, finally, thank God, at least we know what is causing the problem, and perhaps SC guys look at it for fix, or help other guys overcome this issue if they face... grrrrr


                    cheers

                    Comment


                    • #11
                      Ok, Let me talk to the test manager and check it out what is the problem, we might need some additional information about this problem.
                      Best regards,
                      Carlos Lacerda.
                      ScriptCase Commercial Manager.

                      Skype: carlos.lacerda82
                      Email: carlos@scriptcase.net
                      Visit our Blog: http://www.scriptcase.net/blog/
                      Visit out fan page: http://www.facebook.com/Scriptcase

                      Comment


                      • #12
                        simple carlos, let him make simple form (single record) and try add/update/delete all ok on desktop even if the id field is not included in the "Edit fields" section

                        once your remove the id field from "Edit fields" it will work only for desktop! let him/her chaeck the history i wrote in this thread, any more info please let me know and i will explain further.

                        Comment


                        • #13
                          Hello,

                          Issue reported to our bugs team.

                          regards,
                          Bernhard Bernsmann

                          Comment


                          • #14
                            Hello,

                            This bug has been solved on release 8.0.007.

                            ChangeLog:

                            Specific correction - Fixed issue when updating records in the form on mobile devices.

                            Regards.
                            Best regards,
                            Thomas Soares.
                            ScriptCase International.

                            Email: t.soares@scriptcase.net
                            Visit our Blog: http://www.scriptcase.net/blog/
                            Visit out fan page: http://www.facebook.com/Scriptcase

                            Comment


                            • #15
                              yes, the issue was if you don't include the primary id number in the form it wouldn't work! when included the id field and "hide" it it works from both desktop and mobile, but still, sc_redir after update from mobile takes you back to grid with wrong view, check it yourself.

                              Comment

                              Working...
                              X