Announcement

Collapse
No announcement yet.

[SOLVED] Updates to 8.00.0013

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Updates to 8.00.0013

    The following error is present in all of SC8's interface pages (including SC login):

    Strict Standards: Declaration of ADODB_pdo_sqlite::_connect() should be compatible with ADODB_pdo::_connect($argDSN, $argUsername = '', $argPassword = '', $argDatabasename = '', $persist = false, $charset = '') in /opt/NetMake/v8/wwwroot/scriptcase/prod/third/adodb/drivers/adodb-pdo_sqlite.inc.php on line 305


    This showed up after installing updates a few minutes ago.

    (I use MySQL for web services, not SQLite.)
    Last edited by Giblet535; 10-10-2014, 08:31 AM. Reason: clarification

  • #2
    I don't have that issue. SQLite is used to store your application definition. The database you work upon is not used although it can be configured to do so. I think best way would be to do a re-install as something is broken.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      i have this problem to, i suppose that i problem with update

      Comment


      • #4
        I'm going to try reinstalling. Any attempt to "Generate Source Code" fails with this error.

        It's goiing to be painful if I have to switch generators, but SC8 does not appear to be as solid as SC7, and SC7 is unusable.

        Comment


        • #5
          I wonder how you all get to break this stuff. If I see this error message then I think that you have another adodb installation somewhere on your server
          then the one from scriptcase. Although scriptcacse uses the standard one.
          But there have been bugs in pdo_sqlite (and others) so you may want to try replacing that. I guess scriptcase doesnt use the latest version.

          Comment


          • #6
            I reinstalled. That fixed it. For now.

            The 0013 update is what broke it. I don't think NetMake spends much time testing their updates on Linux. I think Linux scares them.

            The way that they install ScriptCase on Linux, it installs its own isolated environment. If there's an ADO conflict, then NetMake owns that conflict since they had to have installed it.

            Then they make that isolated environment world writable so that anyone with access to the server can overwrite any file, any folder. The documentation says the permissions must be like that. That's how I know that Linux scares them. They don't have negligence lawsuits in Brazil, I guess.
            Last edited by Giblet535; 10-16-2014, 05:37 PM.

            Comment


            • #7
              Hello,

              I will discuss this issue with our team.

              regards,
              Bernhard Bernsmann

              Comment


              • #8
                Hello,

                This problem was fixed in update 8.0.014.
                Best Regards,
                John L. Santos

                Bug Tracker Team
                NetMake - IT Solutions

                Comment

                Working...
                X