Announcement

Collapse
No announcement yet.

Buttons Last-Previous Disabled | Botones Ultimo-Atras Deshabilitados

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Buttons Last-Previous Disabled | Botones Ultimo-Atras Deshabilitados

    Hola, tengo un formulario que en el modo de actualización, muestra los registros y los botnoes atŕas y último, se encuntras deshabilitados, mientras que los botones adelanate y primero funcionan normalmente.

    he buscado las opciones de Scriptcase y no encuentro donde volver a habilitarlo o a que se debió esto.

    Estaba funcionando pero ahora no.

    --------------------------------
    Hi, I have a form in update mode , and displays the records back and last botnoes , encuntras are disabled , while the buttons and first adelanate function normally.

    I searched Scriptcase options and can not find where to re-enable it or it was due .

    It was working but not now.

  • #2
    hi Fabritux,
    what is "encuntras"
    do you want to re-enable the insert button!? this is the only thing i could understand, you can't insert new records only update existing records, if that is the case, go to toolbar and add button "insert". if you are using multiple records form, you can define how many records to insert will be available when inserting mode is active

    Comment


    • #3
      Hi, sorry about the fast and ugly typing...

      The problem is:

      I made a form application...the toolbar got Insert update butons...on update you can navigate the records, forward and backward, first and last.

      When the app form open by default open update mode and i set show the first record (In SQL-> Column ASC)...The navigate buttons only work first and next...but back and last are disabled, i can see the buttons but look like transparent and dont work.

      I need enable this for finally the project..but im stopped now..only for this.

      Thx

      Comment


      • #4
        okay, do you have records in "first and next"? can you see them if opened directly from database?
        i'm not sure why you want to always show the first record?!
        is it ok you want to start by update mode? and keep the insert button there!? just why!? why don't you create a search box, then if no records found, redirect to insert new record...

        anyway, here is what you can play with:
        remove back your ASC sorting from SQL
        is your db ok? do you have AI id? check the id (auto increment numbers) you have in the database, if some are missing, or not indexed correctly, i think will make your buttons look look disabled.
        go to toolbar, remove and return the insert/update buttons, see how things are changed
        in help > macros, check macro: sc_apl_conf("Application", "Property", "Value") see its properties you can define many things with the form-start
        try also adding some buttons manually from macros, check in help > macros http://www.scriptcase.net/docs/en_us...sc_btn_display

        Comment


        • #5
          Not work...

          I drop the field PK and remaked but the buttons still disabled.
          i remove order by in SQL

          About the open mode that is the SC set by default. I seelct the fields for the form and open in update mode with the button Insert. then insert data and back to the update with last register...if a i need make a quick search o navigate the records, only can to forward...backward buttons are disabled..

          The AI is setting right...but i dont know about the index...how would be set??

          Some new idea??

          Comment


          • #6
            is it mysql?
            can you create a project export and sql dump to try the same?
            otherwise we might need full screenshots from everywhere to look at your project, it is strange that only those 2 buttons are not working while there is recrods in the database

            ok, one thing did you try to click on them anyway? record changes? can you get the data actually? i mean, it might be CSS issue that showing disabled or something!?

            Comment


            • #7
              yes its mysql, i export the project i create another table and link with the form and the error was repeated...I can insert and read data in mysql by the form, but the button still disabled..

              Comment


              • #8
                ok give us the project as export and a copy of your sql dump, lets have a look, I'm sure there is something else in the project producing this error

                Comment


                • #9
                  I have the same or similar problem.

                  After the latest v8 updates, the navigation buttons on the toolbar ( first page , previous page, next page and last page ) of ALL FORMS of my project are disabled . How I can activate them?

                  Please it is very urgent, since I can not update my clients applications...

                  Thanks.

                  Comment

                  Working...
                  X