Announcement

Collapse
No announcement yet.

Cannot change client encoding of MySQL database! *Urgent*

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot change client encoding of MySQL database! *Urgent*

    I cannot change client encoding of my database from UTF8 (to Latin1). All my Swedish letters are now scrambeled! After pressing save the setting jumps back to UTF8. Need to get this fixed NOW! Where is this setting stored, can I change it manually?

    SC 8.0.020
    Thank you!

    EDIT:
    Restored a backup for now...
    Last edited by HakLin0816; 11-23-2014, 07:31 PM.

  • #2
    You can do this (change the collation) within SC's Database Builder tool (you need to change it at the database / table level). Or via the phpmyadmin tool

    Comment


    • #3
      Really!? The Collation of the database is the same as always, the only thing that has changed is the "Client encoding". And all letters (Swedish) are now scrambled. I would rather be able to change the setting back in SC Prod...

      Comment


      • #4
        Did you try to set the permissions of the _lib folder temporarily to 777?

        jsb

        Comment


        • #5
          Hello,

          What is your Client Encoding of your database?

          What is your Client Encoding of your tables?

          Are your using the same Client Encoding for same options?

          For final, what is your Charset of your Project (language).

          Thank you!
          Best regards,
          Thomas Soares.
          ScriptCase International.

          Email: t.soares@scriptcase.net
          Visit our Blog: http://www.scriptcase.net/blog/
          Visit out fan page: http://www.facebook.com/Scriptcase

          Comment


          • #6
            Hi Thomas

            What is your Client Encoding of your database?
            utf8_general_ci

            What is your Client Encoding of your tables?
            utf8_general_ci

            Are your using the same Client Encoding for same options?
            The only way I could get the Swedish letters to work was by using Latin1 as client encoding in the Collation settings In SC... Otherwise yes!

            For final, what is your Charset of your Project (language).
            ISO-8859-1

            Thank you!

            Comment


            • #7
              Originally posted by jsbinca View Post
              Did you try to set the permissions of the _lib folder temporarily to 777?

              jsb
              I will give it a try, thank you!

              Comment

              Working...
              X