Announcement

Collapse
No announcement yet.

Updating Linux x64 SC8 causes trouble

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updating Linux x64 SC8 causes trouble

    I haven't used SC8 in a long time. There were 703 updates available.

    Once the updates were installed, all of the toolbar buttons in the "Save", "Generate", "Run" group perform only a save operation. "Generate" and "Run" save the current application. That's all they do. Log-out, Log-in don't change this.

    I'm reinstalling. Again.

    When your dev team is testing updates, they should test the Linux builds once in awhile. I know Linux scares them, but they should do it anyway. VirtualBox works really well and it's free. There's no valid excuse.

    Having to reinstall as the only reliable way to update is annoying.

  • #2
    Meh. "Run" still doesn't work after reinstall. It appears to "Save". Time to report it to the bugs team, eh?

    "Run application" doesn't work from the menu either. Deploy-To-Test seems a bit optimistic.

    "Generate" actually works now, though.

    Comment


    • #3
      Hello,

      We have machines with Linux environments in our department and we will perform this procedure.

      At first, you can run the application through the menu? "Application> Run Application"?

      Thank you!
      Best regards,
      Thomas Soares.
      ScriptCase International.

      Email: t.soares@scriptcase.net
      Visit our Blog: http://www.scriptcase.net/blog/
      Visit out fan page: http://www.facebook.com/Scriptcase

      Comment


      • #4
        Hi again,

        I reported this problem to the responsible person and the same want to know some information:

        What is the distribution of your Linux.

        Installation was Scriptcase Manual or Automatic?

        Which browser you are using?

        You updated on what version? (example: 8.0.15)

        Which version you currently have installed?

        Thank you! Wait your response.
        Best regards,
        Thomas Soares.
        ScriptCase International.

        Email: t.soares@scriptcase.net
        Visit our Blog: http://www.scriptcase.net/blog/
        Visit out fan page: http://www.facebook.com/Scriptcase

        Comment


        • #5
          Ubuntu 14.04 x64 (after trying on CentOS 6.6 x64 with the same result)
          Firefox 34.0 (64-bit) and Chrome 39.0.2171.95 (64-bit)

          Installation was automated. Clean install.

          I then imported an existing project, opened that project, generated the code, and tried to run the (very simple) login application.

          Run Application (toolbar or menu) appears to only save the current application. No generate, no run.

          Comment


          • #6
            Hello,

            Check if the browser is blocking the pop-up opens.
            --
            ScriptCase Team

            Comment


            • #7
              No, popups are not disabled (for the SC web).

              SC7 works OK, unpatched bugs aside.

              SC8 used to work fine with the same browsers, OSes, etc. I stopped using SC8 because it's insanely buggy and things keep breaking from one week to the next. I have customers that won't accept "Reported to bugs team." as a reason or excuse.

              I have a few days and decided to give SC8's 703 accumulated updates a try. I assumed that the update process broke the "Generate Code" and "Run Application" functionality, so I removed and reinstalled SC8. That fixed the "Generate Code" problem but "Run Application" still doesn't work. So I installed on my workstation (Ubuntu 14.04 x64). Still broken.

              On a new install, it's around 90% certain that this is a bug. A new install on a new/different platform means it is a bug.

              Grr. Let's try this with the (ughhhh) JavaScript console open...

              Chrome's JavaScript Console spews:
              Uncaught TypeError: Cannot read property 'focus' of undefinedsc_js_Top2_579ccfe88a7f4f39f203e57804e41e 84.js:91 nm_menu_runeditor.php?randjs=8L090krq61jvibMu:478 $.ajax.successjquery.js:2 kjquery.js:2 l.fireWithjquery.js:2 yjquery.js:2 d

              The TypeError occurs at line 91 of sc_js_Top_2_metricboatloadofrandomnumbers.js:
              function nm_menu_run(url_apl, target_apl)
              {
              obj_window = window.open(url_apl, target_apl, '');
              obj_window.focus(); // <------ Right There It Blows Chunks
              }


              See what you made me do? You made me debug JavaScript. I must wash my hands now. It's almost Christmas, ya know.
              Last edited by Giblet535; 12-18-2014, 03:36 PM. Reason: Trying to format the code. Failing. Giving up.

              Comment


              • #8
                Can you follow this tutorial?

                http://support.scriptcase.net/index..../manual-update

                If you don't have success, you can provide to me a remote access?

                Thank you!

                Have a nice day!
                Best regards,
                Thomas Soares.
                ScriptCase International.

                Email: t.soares@scriptcase.net
                Visit our Blog: http://www.scriptcase.net/blog/
                Visit out fan page: http://www.facebook.com/Scriptcase

                Comment


                • #9
                  The original installer I used for the reinstall was the 024 .run file. The day before yesterday...

                  Downloading the manual install, it is now 025.

                  I overwrote the /opt/NetMake/v8 folder's contents with the extracted files.

                  Logging in, I get an Updates Available notification.

                  Same behavior: I open my simple login application (a control app), click the Run Application button, and JavaScript throws an error (still at line 91 of sc_js_Top2.........js):
                  function nm_menu_run(url_apl, target_apl)
                  {
                  obj_window = window.open(url_apl, target_apl, '');
                  obj_window.focus();
                  }

                  obj_window, it seems, is still undefined.

                  The usual checks, clearing cache etc, don't change this.

                  So 025 still has the same issue. But then, I was warned about available updates when I logged in. That's probably just left-behind 024 files confusing the 025 updater, but let's play along and see what the 234 updates do... Nothing for this issue.

                  Same JS error, same line, same source file.

                  Since that window.open() method can return an undefined value, there should be some exception handling there. It's really easy to do that. Just sayin'.


                  As a further test, I created the "Document Library" demo app using default values (default SQLite connection). Same behavior: generate code, open the login app, click "Run Application", and the same error pops in the JS console.

                  -----------------

                  No remote access. Sorry, but I don't see any evidence that your company has any linux experience at all. Look at the default file permissions: world-writable. Wow.

                  Don't take it personally. I don't let neighbor kids drive my motorcycle, either.

                  I'm pretty sure that if you create an Ubuntu 14.04 x64 "Desktop" virtual machine and install SC8 on it, you'll get the same results I'm seeing. You folks install your own Apache/mods, so the only variable - due to Ubuntu updates - is the local PHP and Zend versions:

                  PHP 5.5.9-1ubuntu4.5 (cli) (built: Oct 29 2014 11:59:10)
                  Copyright (c) 1997-2014 The PHP Group
                  Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
                  with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies

                  If you update your VM, you should be at that version.

                  The CentOS 6.6 box where I first noticed this behavior has PHP/Zend:

                  PHP 5.3.3 (cli) (built: Oct 30 2014 20:12:53)
                  Copyright (c) 1997-2010 The PHP Group
                  Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
                  with XCache v3.0.4, Copyright (c) 2005-2013, by mOo
                  with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies
                  with XCache Optimizer v3.0.4, Copyright (c) 2005-2013, by mOo
                  with XCache Cacher v3.0.4, Copyright (c) 2005-2013, by mOo
                  with XCache Coverager v3.0.4, Copyright (c) 2005-2013, by mOo
                  Last edited by Giblet535; 12-19-2014, 10:26 AM. Reason: Forgot to answer the remote access question.

                  Comment


                  • #10
                    No problem,

                    I will ask the responsible for creating a VM with your operating system (Ubuntu 14.04 x64) and perform the upgrades of OS and soon after, install Scriptcase (and update it).

                    Right?

                    Thank you!
                    Best regards,
                    Thomas Soares.
                    ScriptCase International.

                    Email: t.soares@scriptcase.net
                    Visit our Blog: http://www.scriptcase.net/blog/
                    Visit out fan page: http://www.facebook.com/Scriptcase

                    Comment


                    • #11
                      That should do it, Thomas.

                      Merry Christmas

                      Comment

                      Working...
                      X