Announcement

Collapse
No announcement yet.

[SOLVED] Onbur events cause DOUBLE_CLIC on buttons !!! urgent

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Onbur events cause DOUBLE_CLIC on buttons !!! urgent

    Hello,

    After update from v7 to V8, on some screens (control, grid and form) user needs to click twice to functions buttons !!!
    example: validation button on control app, does not validate on first time click bu well on second time
    when using calculator, I need to clock twice on al buttons ???

    I found that when there is onbur event on a numeric fields with calculator, you have to click Twice in calculator !!!!


    Thanks
    Nac

  • #2
    Hello Nac,

    I was able to reproduce the issue, but I'm not sure if this is really a bug. I will pass it on to our bugs/development team for further testing.

    regards,
    Bernhard

    Comment


    • #3
      Afert update at 8.0.27 work for me

      Comment


      • #4
        Hello Bartho

        But with V7 there was no double-clic ????? It's very difficult to explain that to my customers ...

        Thanks
        Nac

        Comment


        • #5
          Hello

          Any solution ???

          Thanks

          Comment


          • #6
            Originally posted by nacyil View Post
            Hello

            Any solution ???

            Thanks
            It's very weird...did you tried to clear cache...scriptcase/tmp folder and regenerate all apps?
            /Giuseppe

            Professional Scriptcase Services
            Some Customers opinions

            Comment


            • #7
              Yes Giu, but nothing change !!!

              Maybe it's because i'm on linux server Centos ????

              Comment


              • #8
                Originally posted by nacyil View Post
                Yes Giu, but nothing change !!!

                Maybe it's because i'm on linux server Centos ????
                I don't think so. I think is more related to client side.
                What browser are you using? Did you tried with other browser?
                /Giuseppe

                Professional Scriptcase Services
                Some Customers opinions

                Comment


                • #9
                  Yes with firfoxe it's the same

                  It's happend with a onajax_events , per example : a numeric field with standard calculator and an Onbur ajax event on this field , open the calculator and you need to push twice on every button.

                  Comment


                  • #10
                    Originally posted by nacyil View Post
                    Yes Giu, but nothing change !!!

                    Maybe it's because i'm on linux server Centos ????
                    No, I use CentOS 6.6 - with latest updates for all apps, and I do not see the problem.

                    Dave
                    Dave Prue
                    Code Whisperer
                    Lahar International Corp
                    www.lahar.net

                    Comment


                    • #11
                      Hello Dave

                      Did you test this :

                      a numeric field with standard calculator and an Onbur ajax event on this field , open the calculator and you need to push twice on every button.

                      Thanks
                      Nac

                      Comment


                      • #12
                        Originally posted by nacyil View Post
                        Hello Dave

                        Did you test this :

                        a numeric field with standard calculator and an Onbur ajax event on this field , open the calculator and you need to push twice on every button.

                        Thanks
                        Nac
                        Hi Nac,

                        Yes, I just tried it with a new form, exactly as you specified, and I get the same failure as you do. The first click executes the onBlur (I get the "processing" message) the second click I get the number that I clicked on (WITHOUT any "processing" message). This happens both in Development and Production modes. I really do not believe that this has anything to do with CentOS since it is happening on my development server as well.

                        I would dig through the generated code and find the exact problem in the generated code and report it to NetMake, except that when I have done that in the past they have not implemented the fixes I have given them.

                        Dave
                        Last edited by daveprue; 03-05-2015, 12:51 AM.
                        Dave Prue
                        Code Whisperer
                        Lahar International Corp
                        www.lahar.net

                        Comment


                        • #13
                          Thanks Dave for spelling time.

                          I don't understand why bug team does not try a simple test ?? I wrote this bug a few days ago and I'm blocked with that by my customers !!!!!!

                          There was no problem in version 7 !!!

                          Comment


                          • #14
                            Hello there

                            I don't understand bug team, no answer, no solution !!!

                            In fact it's easy to reproduce the bug :

                            create a numeric field with standard calculator and add an Onbur ajax event on this field , open the calculator and you need to push twice on every button.

                            Thanks
                            Nac

                            Comment


                            • #15
                              Hello Nac,
                              this problem is not only for numeric fields.

                              I did one grid editable and if i click the pencil to edit row, ( non in modal form ) and i change value from select field i must click update icon two times
                              ( tried on centos, windows, php 5.4 and 5.5 )

                              Netmake, please resolve this !!

                              Comment

                              Working...
                              X