Announcement

Collapse
No announcement yet.

problem in decimal fields

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem in decimal fields

    create a field, whatever it is, change it to decimal (even if changed in db itself) and syhcned, it doesn't take more than 1 digit+ decimal, tried all possible ways no use unless removing the field completely and re-creating it

    http://www.scriptcase.net/forum/show...2644#post32644

  • #2
    That's an improvement.

    I have thousands of "decimal" (floating point) fields. Over 2700.

    I made them all Text, I limit the character input, and I added a lot of onValidate code. Luckily, MySQL and SQLite are both happy with '3.14' as a DOUBLE value.

    It's tacky, and almost as much work as writing the PHP from scratch, but at least a floating point value can be entered by a human.

    I've tried to imagine what kind of creature the "decimal" field type was designed for. I'm thinking they're designed for nose tip data entry. Trained sea lions maybe.

    Comment


    • #3
      okay one more point to add to this bug may help sc guys to find the error faster... it happens only if the field was first select as "something" and then changed to decimal

      now to repreduce, select a field as TEXT, note in SC > field settings, says HTML type = TEXT, DB type whatever, even if double...

      now, change the field to decimal and save, see that HTML type stays "TEXT" so it will act as text

      in my case it was integer and stayed integer, so couldn't add the decimals, untill removed the field comopelelty and when newly created chose and decimal so it worked

      I guess it is a small bug can be solved easy, but still Bartho didn't show up yet, so at least there is a workaround for it, can be considered "low priority"

      Comment

      Working...
      X