Announcement

Collapse
No announcement yet.

Slow Performance in Development Tool when Editing Fields of a Grid Application

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow Performance in Development Tool when Editing Fields of a Grid Application

    I have a grid application with 12 fields. Switching between the different application sections via the menu tree is normally quite fast, i.e. 0.5 - 1 sec. However, I noticed that when I open the fields section and click on individual fields to, e.g. to change the format, it may take 30-60 seconds before the properties of the clicked field becomes available. In the meanwhile the existing section is still shown and a status text at the bottom says: "Waiting for 127.0.0.1..."

    I am developing under Windows 7 on a powerful Intel quad core I7 processor, so I don't see why it has to take so long.

    Incidentally, I have noticed that another grid application with 17 fields takes a full 1,5 minutes to generate.

    Is there perhaps an issue with the performance of grid applications in the development tool getting worse as the number of fields increase?
    Best regards,

    Frank

  • #2
    Originally posted by Orion View Post
    I have a grid application with 12 fields. Switching between the different application sections via the menu tree is normally quite fast, i.e. 0.5 - 1 sec. However, I noticed that when I open the fields section and click on individual fields to, e.g. to change the format, it may take 30-60 seconds before the properties of the clicked field becomes available. In the meanwhile the existing section is still shown and a status text at the bottom says: "Waiting for 127.0.0.1..."

    I am developing under Windows 7 on a powerful Intel quad core I7 processor, so I don't see why it has to take so long.

    Incidentally, I have noticed that another grid application with 17 fields takes a full 1,5 minutes to generate.

    Is there perhaps an issue with the performance of grid applications in the development tool getting worse as the number of fields increase?
    It's not always clear what causes it. I have similare experiences. What might be helpful is to watch the number of meta-data to be retrieved from your database. If the database model is too large it might be helpful to set a filter on the connection to limit the result set. Other option is to watch the number of php / apache processes, sometimes they seem to stack up for some reason eating memory.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      It turned out that the server where the database resides (which is not the Win 7 computer with SC) had some performance issues.
      Your mentioning the amount of meta-data to be retrieved pointed me in the right direction.
      Best regards,

      Frank

      Comment


      • #4
        Originally posted by aducom View Post

        It's not always clear what causes it. I have similare experiences. What might be helpful is to watch the number of meta-data to be retrieved from your database. If the database model is too large it might be helpful to set a filter on the connection to limit the result set. Other option is to watch the number of php / apache processes, sometimes they seem to stack up for some reason eating memory.

        And how can i do that please? Have the same problem and its killing me

        Comment


        • #5
          In your process viewer (windows, not sure in linux) you can see the amount of apache services. If you go to the connection edit you can click on advanced. There you can set filters to limit the tables returned. We use PeopleSoft who has literally has over 10000 tables. You don't want that all in your application.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment

          Working...
          X