Announcement

Collapse
No announcement yet.

Slow development environment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow development environment

    I have a form with about 200 fields. After changing a field's properties (Form Settings | Fields) and clicking on another field, it takes about 30 seconds to bring up the properties of that 2nd field.
    I have a Core I5 with 8GB of RAM (usually about 2GB free) and a decent SSD drive.
    I'm using v8.1.022.
    Does anyone else experience this? Any way to improve response time?

  • #2
    Hi Coach...not sure if this is a help, but thought I would post anyways...

    I had a similar issue, was using Internet Explorer...then decided to try Firefox...made the biggest difference!!

    Comment


    • #3
      I also had problems with a slow development environment at some point. The cause was that the project used a database residing on another server than my development environment and that the connection to that server had some performance issues. So, that would be my first question: Are you connecting to any external databases in your project?

      If not, it may be worth trying out some of the tips for handling slow development performance that Albert gives in this thread:

      http://www.scriptcase.net/forum/foru...id-application
      Best regards,

      Frank

      Comment


      • #4
        Look at the size of your datamodel too. Are all tables enabled and are there a lot? Then try to filter your connection to the tables you need. Scriptcase will download the full model every time which can cause a lot of performance loss.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Originally posted by hbmaddog View Post
          Hi Coach...not sure if this is a help, but thought I would post anyways...

          I had a similar issue, was using Internet Explorer...then decided to try Firefox...made the biggest difference!!
          Thanks for the idea...however, I'm already using Firefox!

          Comment


          • #6
            Albert and Orion...thanks for the ideas. I am connecting to a mysql hosting at Godaddy. Previously, I was using the local mysql on my PC, and I'll switch back to that.
            I also have some obsolete tables in my db that I can get rid of.

            Comment


            • #7
              Your environment's php version might also contribute to that.
              If you are still using php 5.4, switch to the latest 5.6 version.
              Regards,
              Cavadinha

              Development Team
              Netmake - IT Solutions

              Comment


              • #8
                Originally posted by Cavadinha View Post
                Your environment's php version might also contribute to that.
                If you are still using php 5.4, switch to the latest 5.6 version.
                I'm using PHP: 5.6.8 already. I moved mySQL database local and deleted some tables I no longer needed. Didn't really help. I'll put this on a back burner right now....too many other things to work on...thanks for the ideas, though.

                Comment


                • #9
                  Sorry, if this seem like stupid questions, its just that you mentioned earlier that your development database resided on Godaddy, i.e. on a server in the cloud rather than locally. This would often be a sure way to have lags when retrieving large amounts of schema-information when developing and maintaining forms (especially if it is shared hosting), so double checking:

                  a. Besides moving the database to your computer, you also created a new connection in the project pointing to the new database

                  b. Totally removed the old connection to the Godaddy located database

                  c. Checked all applications that they use the new connection to the local database

                  Also, try make a copy of the offending application with 200+ fields (btw, that is an insane number of fields in a form -- I thought my forms were big :-), then remove half of the fields, see if the problem persists, remove half again, etc. If the slow performance is there when you are down to e.g. 30 fields, I would try to recreate the form as a fresh application with just a few fields. Also, create a brand new project with only the new local database connection and a similar form application with just a few fields, and then increase the number.

                  It should be possible by halving / splitting the number of fields, components of the application, etc. to create smaller units which can be proven true or false as having the problem, thus identifying the source. But, I also understand if you are frustrated with time wasted -- I know the feeling :-).
                  Last edited by Orion; 01-20-2016, 03:51 AM.
                  Best regards,

                  Frank

                  Comment


                  • #10
                    TheCoach In the other hand, if you're willing to let us test the performance of the form you can send us your form app + dd.

                    We could test and maybe improve the performance of the apps after we test this locally and check if there is any routine with a bottleneck that we can remove.
                    If you're interested just send me a PM and i'll talk from you from there.
                    Regards,
                    Cavadinha

                    Development Team
                    Netmake - IT Solutions

                    Comment


                    • #11
                      Originally posted by Orion View Post
                      Sorry, if this seem like stupid questions, its just that you mentioned earlier that your development database resided on Godaddy, i.e. on a server in the cloud rather than locally. This would often be a sure way to have lags when retrieving large amounts of schema-information when developing and maintaining forms (especially if it is shared hosting), so double checking:

                      a. Besides moving the database to your computer, you also created a new connection in the project pointing to the new database

                      b. Totally removed the old connection to the Godaddy located database

                      c. Checked all applications that they use the new connection to the local database

                      Also, try make a copy of the offending application with 200+ fields (btw, that is an insane number of fields in a form -- I thought my forms were big :-), then remove half of the fields, see if the problem persists, remove half again, etc. If the slow performance is there when you are down to e.g. 30 fields, I would try to recreate the form as a fresh application with just a few fields. Also, create a brand new project with only the new local database connection and a similar form application with just a few fields, and then increase the number.

                      It should be possible by halving / splitting the number of fields, components of the application, etc. to create smaller units which can be proven true or false as having the problem, thus identifying the source. But, I also understand if you are frustrated with time wasted -- I know the feeling :-).
                      Hi, answer to a,b, and c is 'yes'. I have forms with fewer fields and the response time is fine. So there appears to be a correlation to the number of fields and the response time.

                      Comment


                      • #12
                        Originally posted by Cavadinha View Post
                        TheCoach In the other hand, if you're willing to let us test the performance of the form you can send us your form app + dd.

                        We could test and maybe improve the performance of the apps after we test this locally and check if there is any routine with a bottleneck that we can remove.
                        If you're interested just send me a PM and i'll talk from you from there.
                        I'm not using a data dictionary. Could that be the problem?

                        Comment


                        • #13
                          I just thought I would share this : I switched from Firefox to Chrome and it's working MUCH faster.
                          Saving changes to a field has gone from 25 seconds to 8 seconds.
                          I was also having problems the past 3 days with applications never finishing generating source code. I had to log out and back in....no longer a problem now that I'm on Chrome.
                          In Firefox, too, it was annoying that when I search for a string, it would not return strings that where in the Field Positioning section. With Chrome, no longer a problem.
                          Maybe some Firefox update....anyway, I'm happy with Chrome.

                          Comment


                          • #14
                            Just out of curiousity (and helpful for others) What version of Firefox are you using? Previously, I had the same issues, but Firefox worked great...I currently have no issues with my setup...I will test on Chrome out of curiosity. My response time on localhost is

                            Comment


                            • #15
                              43.0.4
                              For me, on my PC, Chrome is much faster than Firefox when running Scriptcast development environment. I don't see a difference in speed between the 2 for browsing otherwise.
                              I disabled all Add Ons, extensions, deleted temp files, etc. in Firefox and nothing helped.

                              Comment

                              Working...
                              X