Announcement

Collapse
No announcement yet.

Macro not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Macro not working

    The GIRD opens a FORM. On the form there is a button to call another form (to add child record).
    MacroNotWorking_01.png




    when the button is pressed I call another form

    PHP Code:
    sc_apl_conf("fm_t_new_req""start""new"); 
    unfortunately the form does not open
    I can only see the OK button (have no idea where this comes from).

    MacroNotWorking_02.png





    here is the result


    MacroNotWorking_03.png




    Any ideas what is wrong ?

    Arthur
    -----------------------------------------
    Arthur Klisiewicz
    dATA POINT SOFTWARE
    www.datapointsoftware.com

  • #2
    when the button is pressed I call another form
    PHP Code:
    sc_apl_conf("fm_t_new_req", "start", "new");

    unfortunately the form does not open
    I can only see the OK button (have no idea where this comes from).
    Because apl_conf is not to call a form. You have to do an sc_redir after.
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      sc_apl_conf("Application", "Property", "Value")
      This macro allows to modify the property of the application. The user can determine if a Form will start in insert mode, or a Grid starts by filter, etc.
      ...so the HELP is not mentioning anything about this and if this is true HELP really needs to be updated.
      Anyway - thank you for explaining this , I will give a try and if no complains here - then it means it worked.

      Arthur
      -----------------------------------------
      Arthur Klisiewicz
      dATA POINT SOFTWARE
      www.datapointsoftware.com

      Comment

      Working...
      X