Announcement

Collapse
No announcement yet.

The database connection was not found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • The database connection was not found

    Hello.

    Huge panic right now!!

    Deployed my project to another folder on my server which went ok.

    Now when I go back into the development project I can load my SC project and call up any piece of it (form, grid etc.) but when I run any particular piece of it I get the following error now...
    The database connection was not found, contact the system administrator. Connection: conn_mysql
    I go into "Database", "Edit Connection" and test the connection and all is good.

    So why cant I run any of the applications and it doesn't see the connection?

    Please help!



    Just did another test. Went into SQL Builder and I can build SQL statements that run fine.

    Also tested other projects and they have the same problem as above!

    Soon as I run them I get the error?

    Really confused?
    Last edited by instore; 04-28-2016, 05:56 PM.

  • #2
    I confirm,
    if deploy project on the develop host connection not work.

    To solve i have reinstalled scriptcase on another folder

    Gian Luca

    Comment


    • #3
      Database connection you are using is called conn_mysql?

      It's the first time I see something like this. Maybe closing and opening browser again was a possible solution. How you deployed your app?
      /Giuseppe

      Professional Scriptcase Services
      Some Customers opinions

      Comment


      • #4
        Thanks so much "Fregnella"...... You were right. I did a manual install of ScriptCase and the database connection is working again.

        Really weird how just deploying would cause that!!!!

        Giu to answer your questions......

        Yes my database connection was called "conn_mysql".

        Closing browser or trying a different browser did not help in any way.

        I deployed to zip file with typical selections and had checked "Deploy with the common libraries" and "Deploy with the common files(CSS, buttons, images, messages)".

        Seemed pretty straight forward until I tried to return to DEV environment and the errors started.

        Comment


        • #5
          Hi Giu,
          no my connection was not called "conn_mysql", but i have found the reason of problem: FIREFOX. If, without reinstall, i use chrome all work fine


          Gian Luca

          Comment

          Working...
          X