Announcement

Collapse
No announcement yet.

Urgent: Dropdown filed shows question marks instead of characters!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Urgent: Dropdown filed shows question marks instead of characters!

    Hello, I have master/detail, in the detail form when i click drop down it shows me question marks instead of characters!
    I already put this code in event (OnScriptInit) in both master and detail form:
    sc_exec_sql("set names 'utf8'");
    Unfortunately it did nothing, see attached image.
    The strangest thing is: when i submit the row it display the text very well without any problem!!
    Please advice
    Scriptcase V8.1 Enterprise Edition.

  • #2
    Forgot to say that this happen only when i deploy the project on my client website [cPanel]. no problem at all on my local server!!
    Last edited by iiiax; 05-05-2016, 09:37 PM.
    Scriptcase V8.1 Enterprise Edition.

    Comment


    • #3
      Verify if the database is set to the corresponding charset also check the connection settings for the charset, because that only happens when the charset at some point isn't the same. Note that if you inserted any data into the database with a different charset and modify it later, the data will return with the question marks.

      Comment


      • #4
        Thanks so much Mr. Carlos for your help. I checked my DB again, All tables utf8_general_ci, i made express edit to all applications and set the connection to MySQL also add some data just to make sure the issue is not reflected from the old data inserted to DB in different charset, Unfortunately the problem still there..
        any idea?
        Scriptcase V8.1 Enterprise Edition.

        Comment


        • #5
          any idea? .....
          Scriptcase V8.1 Enterprise Edition.

          Comment


          • #6
            Did you check your timezone? I have seen issues like this before. Example of issues other people had.

            http://redmine.webtoolkit.eu/boards/...7#message-8947
            http://stackoverflow.com/questions/2...rom-javascript

            Comment


            • #7
              Dear cacti, thank you so much for your suggestion, i added the following line to the .htaccess file:
              php_value date.timezone 'Region/Zone' then i created php file with the following code to check if my timezone is set and working:
              <?php phpinfo(); ?> Unfortinately that did not solve my problem Still waiting for a suggestion that may help me figure out how to solve this problem. Thanks
              Scriptcase V8.1 Enterprise Edition.

              Comment


              • #8
                The next thing to verify is the character set that is used in the DB.

                Comment


                • #9
                  check this post http://www.scriptcase.net/forum/foru...orking-on-prod

                  Comment

                  Working...
                  X