Announcement

Collapse
No announcement yet.

Best practice for Update SC 7 to 8 and change web server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Best practice for Update SC 7 to 8 and change web server

    Hi,
    Im using SC 7 on a webserver with php 5.3 now and want to change to SC 8 on a new webserver with php 5.5. What is the best way for this?

    Currently I plan this:
    1. Install SC8 on the old webserver
    2. Update SC7 to SC8 (old webserver php 5.3)
    3. Update projects to SC8
    4. Install SC8 on the new webserver (php 5.5)
    5. Copy projects from the old to the new webserver

    At No. 2 and 4 Im not sure, if this is possible.

    Will my plan functioned? How would you do this changes?

    Thank You!!!
    Johannes Jahn

  • #2
    Originally posted by JohannesJahn View Post
    Hi,
    Im using SC 7 on a webserver with php 5.3 now and want to change to SC 8 on a new webserver with php 5.5. What is the best way for this?

    Currently I plan this:
    1. Install SC8 on the old webserver
    2. Update SC7 to SC8 (old webserver php 5.3)
    3. Update projects to SC8
    4. Install SC8 on the new webserver (php 5.5)
    5. Copy projects from the old to the new webserver

    At No. 2 and 4 Im not sure, if this is possible.

    Will my plan functioned? How would you do this changes?

    Thank You!!!
    Johannes Jahn


    Zend guard loader (requisite for SC) don't works on 5.5, you need PHP 5.4 max.

    Are both server on same network? to migrate you just need to access from SC8 to the SC database.

    A possible option is.
    1.- Install SC8 on new server.
    2.- XCopy your sc7 folder to the new server
    3.- Points Conversion wizard to the SC7 folder on your new server.
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      Thank you again.
      Currently I have only webservers with PHP 5.3 and 5.5. So I can't use SC8. Is this right?
      Maybe I could get a webserver with php 5.4 for development only. Would it be possible, that I develop with SC8 on a webserver with php 5.4 and transfer the generated code of my projects to a webserver with PHP 5.5. Or in other words: Is the zend guard loader needed for develooment only, published projects only or both?
      Thank you for your advice.
      Kind Regards
      Johannes Jahn

      Comment


      • #4
        Hello,

        Zend guard loader is only necessary on your development environment.

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          Thank you at all.
          I have installed SC 8 on a new fresh ubuntu server 14.05 on a virtual machine with the Linux installer from the download page. Im using a sqllight - dbms for SC itsself. For the project I will use Maria DB (a clone of mySQL).
          Then I copied the SC7-directory from the old server to the new one and upgraded my project.
          But unfortunalety I cant generate the code. I will open for this problem a new thread.

          Regards
          Johannes Jahn

          Comment

          Working...
          X