Announcement

Collapse
No announcement yet.

SC close my session every N seconds!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SC close my session every N seconds!

    Hi, i am working in SC ver 8.00.0029 it worked fine, but today it closes my session when save my changes appears login and close old session.
    And the new changes are lost.

    I have to configured my scriptcase Session Timeout (min) to 60.

    How can i fix it problem?

  • #2
    I would try to clear cache etc. and try again. If that fails I would try another browser. Are you sure you have set the sto to 60 minutes, not seconds?
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Thanks you Albert, I changed my browser by Opera y Work fine, I think Chrome has some problems technics.

      Comment


      • #4
        Hello ! I'm working with Scriptcase 8.00.0047 . I have the same problem, it only works with firefox ! On chrome I'm only able to login and see the first form. Every other click on other forms or grids on my application give me the "user not authorized or session ended" error message ! Even using chrome incognito mode. Is there a bug working with chrome ?
        Last edited by rzoroddu; 06-14-2015, 05:48 AM.

        Comment


        • #5
          Originally posted by rzoroddu View Post
          Hello ! I'm working with Scriptcase 8.00.0047 . I have the same problem, it only works with firefox ! On chrome I'm only able to login and see the first form. Every other click on other forms or grids on my application give me the "user not authorized or session ended" error message ! Even using chrome incognito mode. Is there a bug working with chrome ?
          Check if you have enabled popups, javascript etc. I actually have no issues with Chrome, although I useually work in FF. But AFAIK both browsers have the same core.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #6
            Hello Aducom an thank you for your answer !
            I've enabled all I can on Chrome browser, I stil got the same error :-(
            No error at all with Firefox and Explorer ! Only with Chrome and Opera :-(
            And no error at all on other hosting provider, with same database and same application files !
            Can't get rid of it...

            I feel is a security problem... Do you know if there's some parameter in order to set up a session timeout ?
            I've set a 9999 at a develop level of scriptcase because it logged me out quickly when working but... it wasn't at prod environment

            Thank you !
            Raimondo

            Comment


            • #7
              There are session timeouts in php.ini as well as apache, but afaik if you installed from a sc version then we all have the same source. But you could try to re-install although you must create a full backup previously to prevent issues and export your applications to be able to restore them in the new SC.
              Albert Drent
              aducom software netherlands
              scriptcase partner, reseller, support and (turn-key) development
              www.scriptcase.eu / www.scriptcase.nl

              Comment


              • #8
                FF and chrome have a differenet code. chrome is webkit based and ff is gecko based. But that is beside the point. I suggest getting a PORTABLE CHROME and trying with that one. If that works properly then the problems lies in the fact that your chrome is simply damaged in some way. In this case you need to reinstall your chrome.
                Alternatively you can use maxthon which is chrome based. If chrome fails then maxthon should also fail.

                Comment


                • #9
                  Originally posted by rr View Post
                  FF and chrome have a differenet code. chrome is webkit based and ff is gecko based. But that is beside the point. I suggest getting a PORTABLE CHROME and trying with that one. If that works properly then the problems lies in the fact that your chrome is simply damaged in some way. In this case you need to reinstall your chrome.
                  Alternatively you can use maxthon which is chrome based. If chrome fails then maxthon should also fail.

                  Will try and let you know !

                  Thanks for your answer :-)

                  Raimondo

                  Comment


                  • #10
                    Here we are !

                    I've downloaded and installed the latest version of Portable Chrome : no way, the problem persists...

                    You can try if you want , just reach booking.sardaterra.com with user "boxlacaletta1" and password "boxlacaletta1" .
                    If you click on every item on the left tree menu, you will have the error on the right body.
                    It happens only with Chrome an Opera, in every way (Normal, totally cleared cache , Incognito, Mobile), and now on Portable Chrome too !

                    Repeat it on Firefox or Explorer and everithing will be alright.

                    I've tried with the same DB and the same Scriptcase files on another hosting and it runs with all browsers and in every way !

                    you can try at www.supracom.it/booking with every browser...

                    AFAYK, is there a "special" Scriptcase Production Environment folder where it writes down some "temporary" file or manage with security files ?
                    The error I always get is for "anouthorized user or session ended" ...

                    Thank you !
                    Raimondo


                    If you try wit Firefox or

                    Comment


                    • #11
                      I tried it with a portable chrome and it works as it should.
                      My portable chrome version is 40.0.2214.115.
                      So I installed the latest version which is Version 43.0.2357.124 this one works fine too..

                      So maybe you installed some extra stuff in there... Over here I see a VOUCHER/AGENZIE/REPORT etc...

                      Comment


                      • #12
                        That's incredible ! Than you're able to see every form in the app !?
                        Well, I'll try to uninstall Chrome, regclean and then try to re-install Chrome Portable , the same version you've used on your test ! Will let you know ;-)

                        Thank you, wish me luck !
                        Raimondo

                        Comment


                        • #13
                          Here is your proof from 3 random screens on my portable chrome latest edition....
                          Attached Files

                          Comment


                          • #14
                            Originally posted by rr View Post
                            Here is your proof from 3 random screens on my portable chrome latest edition....
                            Yes, sorry, but may be I wasn't able enough to explain the scenario :-)

                            To know if everithing is right you should try with Chrome (Normal, portable and mobile) on booking.sardaterra.com server.
                            I've seen your screeenshots and they all are from supracom.it/booking, server where I have no problem at all.
                            That's the strange, on both servers we have the same scriptcase files and the same database !

                            Could you please have a try on booking.sardaterra.com server with the same credentials ?

                            Thank you very very much !
                            Have a nice day :-)
                            Raimondo

                            Comment


                            • #15
                              Ok it does work as well. But you left a debug option on somewhere since I get some output boxes. I click them away and I can simply login (portable chrome again).
                              Check your events and check your debugging options.

                              Comment

                              Working...
                              X