Announcement

Collapse
No announcement yet.

scriptcase update stop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    If this runs on your local machine then it's most likely not a security issue (write rights) but hard to tell. Final option would be to create a full diskcopy of your scriptcase environment and do a fresh install.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #17
      This is definitely something with their update system. I have been experiencing the same issue for the past 2 days, stopping on the same exact file as posted earlier. This is on 2 different linux vps servers that have been in use for over a year and this is the first time I've had an update issue. The folder permissions are fine and nothing has changed on these systems since they were set up. I have notified SC as well and they are supposed to be checking into it.

      Kevin

      Comment


      • #18
        i update in manual mode

        Comment


        • #19
          guys, update manually and get headache free, I do that because always with automatic udpate get error and each time different scenario.. update manually with care it will replace and merge files and i will keep the zip file so can be replaced if new version have old bugs instead of solving them loool

          cheers

          Comment


          • #20
            On Linux it is is /etc/php.ini that holds sway ... that is unless you chose to use the webserver that came from NetMake. In the latter case, it would be the php.ini that is below the ScriptCase installation root.

            Comment


            • #21
              Originally posted by Sean H. View Post
              It is a bug.
              The PHP process is running out of memory at the point of the update as evidenced in the webserver error log (/var/log/httpd/error_log).

              SOLUTION
              Edit your php.ini file
              Look for the line memory_limit
              The default value there is 128M and is usually more than enough.
              Increase it to 192M or 256M, restart your webserver and it will work.
              ... you can reset it afterwards to the default value.

              SCRIPTCASE:
              This does qualify as a bug as there should be no need to allocate that much memory to update a few files.

              Thanks man! This solution worked for me.

              Comment


              • #22
                Could Netmake give a offline upgrade package to download? Every upgrade is so hard and take several days even.

                Comment


                • #23
                  Originally posted by jerry View Post
                  Could Netmake give a offline upgrade package to download? Every upgrade is so hard and take several days even.
                  here you go, untick "I would like to receive newsletter" otherwise it will count you new user and create a "dummy account" for you and you will end up with reminders from sc team to purchase and that support is available, and they can help you - all automated, 100% bla bla

                  http://www.scriptcase.net/download-scriptcase/

                  just untick that and download the manual version, but be careful, backup your version first, close your development environment, open the manual zip file, open your scriptcase root, highlight all files including the folders like app, backup, conf..etc in the zip and drag-drop to your scriptcase root (folder shroud have same folders names to override) and windows will ask you to merge and replace files...click yet, give it time, because basically it will replace all files and merge the rest like in app and others... not like the automatic update I think it checks and compares all files then replace what is needed only... not sure.

                  I'm assuming you have windows 7 or 8, in all cases, DO IT AT YOUR OWN RISK.

                  Comment

                  Working...
                  X