Announcement

Collapse
No announcement yet.

URL Output of Security not Working?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • URL Output of Security not Working?

    As far as I can remember in ver 7, if I set "Use Security" in app A to Yes and place an app name, say B, in "Url output of the security", once an attempt is made to access A without authentication, SC immediately transfers control to B (usually the log in app). I find that in ver 8, "Unauthorized User" comes up with a button.

    How can I get the desired behaviour of going automatically to app B without a prompt?

  • #2
    hi

    remove the security from login app, otherwise the user will not be able even to put user/pass eh!?

    add it to all other apps (you can do that from tools > express edi)

    now make sure you setup all the security module from creating users and having them added permissions to wanted applications

    if user access unauthorized application it will kick him to login screen, once user and password are correct then they will have access to given applications by clicking them from your menu (usually)

    you can however to disable the security while you developing from "my scriptcase" go there and remove the tick from the options to work on your project without security limitations (in development only)

    Comment


    • #3
      Thanks MikeDE, let me clarify:

      hi

      remove the security from login app, otherwise the user will not be able even to put user/pass eh!?

      ==> no of course I don't have security on the log in app

      add it to all other apps (you can do that from tools > express edi)

      ==> sure this was done before
      now make sure you setup all the security module from creating users and having them added permissions to wanted applications

      ==>yes this was the case before
      if user access unauthorized application it will kick him to login screen, once user and password are correct then they will have access to given applications by clicking them from your menu (usually)

      ==> before going to log in screen, it is first showing "unauthorized user" and when I click the button, it tries to go to the login app. That is the bevahiour I want to correct: it should not show me this message. It should just go to the login app straight.

      you can however to disable the security while you developing from "my scriptcase" go there and remove the tick from the options to work on your project without security limitations (in development only)

      ==> yes I'm aware of this

      Comment


      • #4
        Originally posted by scriptcaser View Post

        ==> before going to log in screen, it is first showing "unauthorized user" and when I click the button, it tries to go to the login app. That is the bevahiour I want to correct: it should not show me this message. It should just go to the login app straight.
        strange, never faced this, unless you have wrong settings

        the only reason could be:

        check your application > navigation > redirect URL

        there should be the login app that you are going to it when you click the ok button

        in this case means you don't have access to your current app, then check your settings, permissions... now go to your login app, add qualified user and go back again to your application, it will say unaurhotized user!? I'm sure it will not, but if yes, then your user needs permissions... if all works wrong, then remove the cache and start over, try also to disable the security and see what happens.. I'm sure there is some wrong setting there

        Comment


        • #5
          Originally posted by MikeDE View Post
          the only reason could be:

          check your application > navigation > redirect URL

          there should be the login app that you are going to it when you click the ok button
          But that's the whole point: why do I need to click the OK button first? If you log out of your Yahoo account and go back in your browser history to one of the emails you read before logging out, Yahoo takes you straight to log in page without fuss. Why is Scriptcase not doing this? And Yahoo is just an example: every standard application simply goes to the log in page if the session has expired.

          Possibilities: (1) there is a problem with my own set up (2) there is a configuration I need to change and (3) this is the only way SC works. I would like to know which is the case.

          Comment


          • #6
            yes, this is the way SC security module works by default, if user is not permitted, will show that message and by clicking ok will take to the application that is configured in that URL, now if that doesn't suite you, i think you can change this behavior by playing with security module applications.

            Comment


            • #7
              Originally posted by MikeDE View Post
              yes, this is the way SC security module works by default, if user is not permitted, will show that message and by clicking ok will take to the application that is configured in that URL, now if that doesn't suite you, i think you can change this behavior by playing with security module applications.
              Would you know which one? Since this behaviour attaches to all apps that have "Use Security" ticked, I would think this is a piece of code that is included to all ticked pages. I'm not sure that piece of code is available for modification.

              Thanks

              Comment


              • #8
                Not really, I checked and couldn't know where exactly, sorry.

                If you could manage to overcome this please post, thanks.

                Comment


                • #9
                  I am new to SC, testing prior to purchase and I too had the same problem. I could log in with the Admin user, but not with the regular user. I tried turning on all access permissions for the regular user. No joy. I tried setting the regular user to priv_admin = "Y" in sec_users (in phpmyadmin). No joy. Then when looking at the user records in SC, I noticed that the Admin user was set to Admin but the regular user was not set to anything. I went to sec_users_groups and sure enough, the group_id was blank for the regular user. I set it to 2, the value for regular users and all was sweet.

                  Hopefully this will help some others who are banging their heads against the wall on this.

                  Comment


                  • #10
                    Originally posted by jarea View Post
                    I am new to SC, testing prior to purchase and I too had the same problem. I could log in with the Admin user, but not with the regular user. I tried turning on all access permissions for the regular user. No joy. I tried setting the regular user to priv_admin = "Y" in sec_users (in phpmyadmin). No joy. Then when looking at the user records in SC, I noticed that the Admin user was set to Admin but the regular user was not set to anything. I went to sec_users_groups and sure enough, the group_id was blank for the regular user. I set it to 2, the value for regular users and all was sweet.

                    Hopefully this will help some others who are banging their heads against the wall on this.
                    Hi jarea,
                    no need for all that actually, just make sure the regular user group permissions from groups x apps application are all set ok, as view, modify, print..etc. otherwise regular user will not be permitted to use that specific application, but admin will do use them because priv_admin='Y' for this group, and it will include all available application by default when you first create the security module, any other application, you need to give permissions from groups x apps again, even for admin.

                    cheers

                    Comment

                    Working...
                    X