Announcement

Collapse
No announcement yet.

Is there a Smart Work-around to Combine a Multi-Select with Auto-Complete

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is there a Smart Work-around to Combine a Multi-Select with Auto-Complete

    I have a varchar field to store the numeric id values of a bunch of choices (comma separated). Alas my poor users need to scroll through a list of 200 items to choose from. Auto-complete seems to work only for single items. Is there a way to achieve this objective: i.e. autocomplete but with multiple choices?

  • #2
    Not so far:

    Work around, create a capture link to a control application to list all the id values you need, so he can do something like a quicksearch.

    Regards

    Comment


    • #3
      Originally posted by kafecadm View Post
      Not so far:

      Work around, create a capture link to a control application to list all the id values you need, so he can do something like a quicksearch.

      Regards
      I had been fiddling with this. So I have a modal control app that pops up and allows me select multiple id values into a session variable (comma separated). The problem is when I exit and return to the main app, I find nothing to update a field with the selected items. It's not really useful if the user returns to his app and has no clue what he has chosen.

      SC seems to only allow update of a another Select/ Double Select field based on a changed value of another by Ajax.

      Or is there another way to get this done?

      Comment


      • #4
        If u have the field that in control as part of your main app that u r talking about, just make control close on ok and use redire to ur main app it will refresh it, happened with me few days ago check my previous threads you will find it im on mobile now

        Comment


        • #5
          Another think I would do is to display all theoptions into a double select field, i think it has what you need since they can type in stuff while they navigate.

          Regards

          Comment


          • #6
            Originally posted by MikeDE View Post
            If u have the field that in control as part of your main app that u r talking about, just make control close on ok and use redire to ur main app it will refresh it, happened with me few days ago check my previous threads you will find it im on mobile now
            This means the whole screen changes to the multi-selection page and returns to the original screen after the choice. That would be the last resort as this is better a modal pop-up.

            Comment


            • #7
              Originally posted by kafecadm View Post
              Another think I would do is to display all theoptions into a double select field, i think it has what you need since they can type in stuff while they navigate.

              Regards
              I started with double select but noticed on mobile devices without a physical keyboard, the soft keyboard does not pop-up. So the users only option is to scroll through a lengthy list.

              Comment


              • #8
                Originally posted by scriptcaser View Post
                This means the whole screen changes to the multi-selection page and returns to the original screen after the choice. That would be the last resort as this is better a modal pop-up.
                YES, modal, keep it modal that is the best, thats why I'm saying this, meanwhile, when return to the main app it will refresh it and hence you have the new data affront of the user right away

                see this
                http://www.scriptcase.net/forum/show...id!-(sc_exit-)

                Comment


                • #9
                  I've checked this and you guys make it seem so easy: why am I not having same results?

                  Please see these pics. Slide2 shows the image field (a plus sign) that activates the control app by link as "show in same winow". But for some reason you will see in slide3 that it is showing some strange toolbar stuff (theme selection which should only show in IDE and the navigation buttons which I removed from the app and also from the link properties).

                  Further when I click Done, it doesn't return to the correct app (I have a friendly URL called "interactions" for the app "form_interactions". The is less of an issue anyway as I can rename the app and get rid of friendly URL but why the problem in slide2?
                  Attached Files

                  Comment


                  • #10
                    Originally posted by scriptcaser View Post
                    I've checked this and you guys make it seem so easy: why am I not having same results?
                    yes, it seemd hard to me too, but it was easy afterall

                    okay, first we agree that you want to open your new intreraction form as modal, put your link paramters ok and chose to close the button on exit

                    now in the modal app put the sc_redir back to your original form main_app

                    those toolbars i'm not sure is it a grid or form or something else, maybe you are removing them from the wrong place as grid, search or summary or something

                    maybe I need to have a look at your project, if you can't export it with the sql dump I can have a look at teamviewer but not now, like after 5-6 hours from now

                    regards

                    Comment


                    • #11
                      Originally posted by MikeDE View Post
                      yes, it seemd hard to me too, but it was easy afterall

                      okay, first we agree that you want to open your new intreraction form as modal, put your link paramters ok and chose to close the button on exit

                      now in the modal app put the sc_redir back to your original form main_app

                      those toolbars i'm not sure is it a grid or form or something else, maybe you are removing them from the wrong place as grid, search or summary or something

                      maybe I need to have a look at your project, if you can't export it with the sql dump I can have a look at teamviewer but not now, like after 5-6 hours from now

                      regards
                      Thanks for this offer I will work on getting across.

                      Comment


                      • #12
                        sorry didn't make it home the other night, we stayed out all the night

                        lets just go over this again:

                        1- you have the main app, is it grid or from? i guess grid - fine
                        2- you have the control form which is popued up from the grid (as modal) and has some values actually existed in the same grid - that is fine
                        3- in your grid, when making the link to your control, just make it modal, close after submit... set width-height...etc
                        4- in your control, add onValidate event the sc_redir to your grid... don't forget the sc_commit macro before the sc_redir in order to send the data to your db before going back to grid
                        5- for your toolbar buttons issue, again, if it is a grid, check other toolbar places in the same grid app, or if you have it as master details check all other applications, it might not be the toolbar that you are removing buttons from.

                        thats it, what is the so hard to do? it is proven working with me and adz, if the above points are not correct, please make for us simple explanation like the one above.

                        Comment

                        Working...
                        X